Sign in with
Sign up | Sign in
Your question

Is it my mobo?

Last response: in Motherboards
Share
January 5, 2013 1:58:17 AM

Hello, I have a rampage iv extreme mobo which is about 6 months old, recently it had been slow to start before one day it stopped completely. Being naive I thought it was the psu without testing as it was the oldest remaining part and bought a new one....for it to not work either. So i unplugged everything and only had the psu plugged in, still not working, finally moving onto leaving the mobo unplugged, unpowered (without battery as well) for the night before trying again in the morning. It finally worked, so I slowly plugged everything back in one at a time before the pc was running and back together. Just got back from a day trip away wheremy pc was off for the time and it is not turning on again. What is the problem and what can i do?

More about : mobo

January 5, 2013 2:03:20 AM

well did you check the 4 pinned slot? many times people forget when they add something or something comes out they unplug certain things, it could be that you just need too redo the wiring since it worked for you before, re attach and see if any wires are chipped, split, fractured in any or bent, anything thing like that can cause the motherboard to improperly read the power voltage and not work.
ALSO! try to boot up with 1 stick of RAM i know it sounds crazy but its worth a shot.

I know MOBO's can be frustrating man just stick in there and well figure it out! :D 
January 5, 2013 2:28:31 AM

I'll pull it apart again and see if it goes with just the psu plugged in. I did previously take it out of the case and only had the24pin in to make sure it wasn't a case short, even then it didn't work till the day after. I hope it's not a capacitor on the mobo because it's basically new.... :( 
January 6, 2013 6:31:29 AM

pulled it apart and carefully put everything back in, and when i hit the start button it took about 5 seconds to turn on, which is very odd, on top of that the onboard sound isn't working now even though the bios and software settings are all on.
!