Sign in with
Sign up | Sign in
Your question

Sabertooth 990fx R1

Last response: in Motherboards
Share
January 5, 2013 9:21:56 AM

Hey Guys, need some help.

I have the above mentioned mobo and have been runnin it flawlessly for around 10 months. woke up today and turned it on. Hung at the Press Delete for UEFI BIOS screen, and i noticed that the BOOT_DEVICE_LED is red and staying on constantly. no system beeps either, and none of my 3 keyboards are responsive to the system. I cant even boot into BIOS. tried everything that i can come across on the web to fix it.

CMOS reset
Unplug all USB and SATA connections
Only try 1 SATA connection at a time.

MOBO passes CPU Check, MemOK!, and GPU check.

Any help would be appreciated.

SYSTEM:
Sabertooth 990 FX
XFX AMD Radeon HD 6870
G. Skill 1600 Ram (4x2GB)
Corsair 850w PS
AMD FX-6200 CPU
WD Caviar Black 1TB
ASUS DVD+-RW OSD

More about : sabertooth 990fx

a b V Motherboard
January 5, 2013 10:12:16 AM

Have you check the manual and asus support for the error?
January 5, 2013 10:58:38 PM

yeah i have. Done everything i can find on there. >.<
Related resources
a b V Motherboard
January 5, 2013 11:11:53 PM

Do you have any old PS/2 keyboards, or USB-PS/2 connectors? Also, did your power go out over night?
January 6, 2013 12:13:24 AM

yeah, have tried a PS/2 keyboard on the Comp as well, i know it works (came form my brothers comp). and to my knowledge the power didnt go out or even flicker the night before.

im getting frustrated and annoyed here.

i have, since first post, bare bones run it out of the case, checking every part i can, and nothing changes. should i RMA it to Newegg?
a b V Motherboard
January 6, 2013 6:36:47 AM

So where does it fail? It passes CPU, Memory, and GPU, next is either add-on roms for raid and such, then Windows. It just not booting to the windows partition and you can't change it because you can't get the keyboard to work? Also, have you tried a boot disk, any, windows, does, linux, etc.? You also tried with one memory stick, then the other? And physically reset the bios, either jumper or pulling the CMOS and shorting. I feel your pain, I'd be pulling my hair out. If you can't even get the keyboard to work, there's not more to do at this point than RMA.
January 6, 2013 9:36:33 PM

it seems to be failing at the BOOT_DEVICE_LED on the motherboard. But i have tried the HDD and the CDROM on another computer and they both work flawlessly. the ram i have also tried in another comp, MINE (cause the 2 comps are practically identical). the power supply is good, the only thing i havent tried is a CPU swap. And i doubt its the CPU as it passes that check everytime.

The Comp WILL NOT go past the "press DELETE for UEFI BIOS" screen, and have tried 3 different keyboards, 1 of which is a KNOWN working PS/2 keyboard.

Guess its RMA then. THanks guys for all your help.
!