Crossfire 5870 problem

When I play Bad Company 2, I get stuttering when I play in crossfire mode UNLESS v-sync is on (this causes FPS drops during explosions and other quick intense moments). I am not really looking for a way to fix this but can someone explain why?


Motherboard
Crosshair IV Formula

Processor
AMD Phenom II X4 965 3.4 ghz overclocked to 3.8ghz

Memory
G.SKILL 6GB (3 x 2GB) 240-Pin DDR3 Triple Channel

Video Card(s)
2x XFX HD Radeon 5870 (CF)

Hard Drive(s)
1 TB

Power Supply:
Corsair TX950 950W

Operating System:
Windows 7 Home Premium 64-bit
10 answers Last reply
More about crossfire 5870 problem
  1. That can happen in games where the alternate frame rendering technique of crossfire is used (which is most of the time actually). You can check here to learn more

    http://www.tomshardware.com/reviews/radeon-geforce-stutter-crossfire,2995.html

    v-synch basically syncs the frame rates to the monitor in order to avoid tearing. If your refresh rates is 60hz then you can't get more than 60fps with v-synch. It sounds to me like your cards want to render some frame faster, but then slow down if they have to wait on resources (ie your CPU) so vsynch forces them to be more even in the delivery of frames.

    You should consider adding a 4th stick of the same kind of RAM (same timings and everything of course) in order to run the RAM in dual channel. Right now your RAM is in single channel due to having 3 sticks rather than an even 4. It's generally only a small increase in performance but an easy one to implement.
  2. I am just gonna set you straight on your RAM first, you are running single channel. That board only supports up to dual channel, but you are running 3 DIMMs, setting you back to single channel. As for the video cards, you are probably just overloading your FPS on your monitor, and v-sync fixes that. You shouldn't drop FPS during the explosions with v-sync with that set up either.
  3. HostileDonut said:
    You shouldn't drop FPS during the explosions with v-sync with that set up either.


    Is that because of my current RAM setup? It's not that bad really.
  4. melonpaste said:
    Is that because of my current RAM setup? It's not that bad really.

    No, your RAM isn't causing that, your RAM is fine, I was just saying it isn't dual or triple channel. I am saying that you shouldn't be getting FPS dips more than 2-5 FPS for longer than a half second, That is what v-sync does, it syncs your frames to your monitor refresh rate. Don't worry about your RAM. It's still good.
  5. HostileDonut said:
    No, your RAM isn't causing that, your RAM is fine, I was just saying it isn't dual or triple channel. I am saying that you shouldn't be getting FPS dips more than 2-5 FPS for longer than a half second, That is what v-sync does, it syncs your frames to your monitor refresh rate. Don't worry about your RAM. It's still good.


    So what do you suggest I do if I am not supposed to get those FPS dips during explosions?
  6. melonpaste said:
    So what do you suggest I do if I am not supposed to get those FPS dips during explosions?

    Well, what I am saying is with CF hd5870s, you shouldn't be having any problems. How much does it dip? At least with v-sync you shouldn't, unless you are using a high refresh-rate monitor.
  7. HostileDonut said:
    Well, what I am saying is with CF hd5870s, you shouldn't be having any problems. How much does it dip? At least with v-sync you shouldn't, unless you are using a high refresh-rate monitor.



    http://ncix.com/products/?sku=55964&vpn=EW2420&manufacture=BenQ

    This is my monitor.

    It feels like 25-30. I didn't check with fraps.
  8. what you can do is enable Vsync combined with tripple buffering. The only way to properly enable tripple buffering with ATI/AMD cards that im aware of, is with Rivatuner.
  9. The RAM you bought was a Kit for the Lynnfield Intel systems' Triple Channel rig. AMD does not use that.

    RAM aside, have you check the performance of the card with a benchmarker?
  10. Like I said, as far as RAM you're best off adding a 4th stick with the exact same speed and timings of the other 3 and run them all in dual channel. As for the dips I'm going to say that it's likely your CPU not keeping up with the demands of your GPUs. You may want to disable any background programs running when you play, especially a resource intensive virus scanner.
Ask a new question

Read More

Radeon Crossfire Graphics