Closed Solved

I bought a new motherboard and I got problems....

Hello,
I upgraded a really old computer that I have had for a long time. I bought a new mother board, video card, dvd drive, processor, 4GB of RAM and a 500GB harddrive.
I installed all of them into the computer myself and everything seemed fine, until I turned it on. When I turned on my computer there was no beep and the video card fan was working and the PSU was working too, but the Processor fan was making little tries to turn on but would just kinda nudge and stop. On and off. Also there is no picture on the monitor. PLEASE HELP! This is my first time building a computer but I asked one of my friends that has done this before to tell me about any precausions and I did. My NEW system is:

Motherboard: Biostar A880G+
Video card: Biostar Radeon HD 5000 Series
Processor: AMD Athlon 2 Mulit-Core Processor
RAM: 4GB (2 Sticks)
PSU: Logisys 550W

Also another thing to bring up is that this PSU does not have a 4 pin for the ATX PWR2 spot... DOn't know if that affects it.
7 answers Last reply Best Answer
More about bought motherboard problems
  1. Best answer
    If you don't have the AUX 4pin or 8pin power plug plugged in then it wont' work. Get a new PSU.
  2. Or get a moles to 8 pin adapter.
  3. + either get a new PSU*** or get an adapter.
  4. Considering that he has a logysis, I'd get a new PSU over using an adapter.
  5. I got a new PSU and It fixed the problem thanks!!
  6. Best answer selected by CCall.
  7. This topic has been closed by Mousemonkey
Ask a new question

Read More

Radeon Graphics Cards Motherboards Computer Graphics