Sign in with
Sign up | Sign in
Your question

USB 3.0 Issues

Last response: in Motherboards
Share
January 7, 2013 1:02:33 AM

I just recently built my new computer and am having issues with USB 3.0. My mouse and keyboard ( Razer naga molten, and razer blackwidow ultimate 2013) will not work if they are plugged in to the USB 3.0 ports but will work with USB 2.0. Also i just recently purchase Bose Companion 5 speakers and those will also not work with a 3.0 but do work with a USB. 2.0. I have all the drivers for my keyboard and mouse that i am aware of ( razer auto installs them / alerts you when there are new ones) but they still won't work? And the speakers aren't ancient so they should work on 3.0 and they still will not and I am not aware of any speaker "drivers" that there may be. Does anyone know what this problem could be? I am using the installed 3.0 ports on my motherboard and I know that they work because i installed the newest motherboard drivers when i purchased it.

My motherboard is a: ASUS P8Z77-V PRO LGA 1155 Intel Z77 HDMI SATA 6Gb/s USB 3.0 ATX ( http://www.newegg.com/Product/Product.aspx?Item=N82E168... )

More about : usb issues

a b V Motherboard
January 7, 2013 1:26:02 AM

Is usb3 enabled in the bios? although this should be enabled by default if the option is even available (is it on my amd motherboard).
Check device manager to make sure the usb3 drivers are actually installed.
Have you tried using a usb3 flash drive?

There is no benefit from running a mouse and keyboard in usb3 ports as far as i know.
m
0
l
January 12, 2013 5:42:25 PM

Sorry for the late response, I tried to install the USB 3.0 drivers, but that didn't do anything, the USB 3.0 still will not work with my mouse and keyboard. I have tried to use a flashdrive in the USB 3.0 ports and that works. The reason i need my mouse and keyboard in USB 3.0 is I am out of 2.0 slots and I need to plug my speakers into a USB port but the available are only 3.0.

I have a USB 3.0 port on the top of my case and when I plug my mouse into that i get the windows bing and my mouse gets power ( it lights up ) and then a message comes up at the bottom right of my screen that says "Device drivers installed successfully, the device is ready to use" but I can't scroll my with my mouse or move it around to get the pointer to move. After taking it out of the USB slot, which is the one i tried my flash drive in, and plugging it into one of the back USB 3.0 slots that are on my motherboard i don't get a windows bing or anything.
m
0
l
!