ASUS 6970 Issue - New system

Hello,
I'm having some issues and I can't, for the life of me, figure out what's wrong, I'm going to try to explain it as best I can.
My new system looks like this;
CPU: i5-2500K @ 3.30GHz
CASE: Antec P193 V3
CPU Cooler - Coolermaster Hyper 212+
Mobo: ASRock Z68 Extreme3 Gen3
PSU: OCZ GameXStream 850Watt
GPU: ASUS Radeon EAH6970 DirectCU II 2GB
HDD: 500GB Western Digital


I start up my computer and notice that my Aero isn't being transparent. I immediately think it's an error with my GPU and start up CCC. The problem is that CCC doesn't work, it just starts up and looks like this;



I've checked dxdiag and it displays my GPU fine.
Everest seems to be fine as well.

GPU-Z looks like this;



I tried to run 3dmark11 to see if it really was the GPU, but when i started it up I got this message;




I really have no idea whatsoever might be wrong, and I was hoping someone could help me out, I would really appreciate it!
14 answers Last reply
More about asus 6970 issue system
  1. Looks most likely problem with amd driver and ccc. You probably done it already, but reinstall them in case you haven't.
  2. I suggest you uninstall the AMD drivers using a tool like Driver Sweeper (http://phyxion.net/Driver-Sweeper/Driver-Sweeper/). Then download the latest Drivers (ver. 11.9)(http://support.amd.com/us/Pages/AMDSupportHub.aspx) and install them. Remember to re-start the computer after removal and install. If this is a new build, make sure windows is updated until it says no more updates. Do this before you install the drivers. One other thing, did you install the chip set drivers after installing windows?
  3. I did try to remove the AMD driver and install the newest 11.9 version, but did not use Driver Sweeper will try that out.
    I downloaded and installed all the drivers for my Motherboard from ASrock's website after I installed windows, yes.
  4. I just used Driver Sweeper, reinstalled the AMD driver and installed the Windows Updates that I could find.

    Once I had done that and did a restart everything seemed fine, I even tried out 3dmark11 and I got a graphics score a bit higher than my previous tests.
    Now, I had a hunch that if I restarted the whole thing would happen again, like before, so I did and lo and behold the same exact issues arose.

    I am really at a loss here, I have no clue what the problem could be.
  5. Try install older driver.
  6. +1 clean and reinstall old driver: it worked.

    I dunno what amd is doing with faulty drivers but they better sort that out.

    Nvidia FTW!!!
  7. So, what's the latest working driver you recommend me getting?
  8. Just try until you get something or you give up and return the card. I say 3 to 6 different driver.
  9. Are you getting any errors from the install package log? As a shot in the dark, try downloading each item individually. And then install 1 at a time after reboots and checking to see if it is working. From what you are saying it is only ccc that is a problem?
  10. I am assuming you have windows 7? Un-Install all drivers for AMD and your motherboard. Re-install all drivers. If that does not work I see you are running a z68 board which also has on-board graphics I believe. Try disabling your on board graphics (if that is possible). Sorry I have no experience with Sandy Bridge chipsets yet. If all else fails re-install windows with a fresh format of the whole drive (Last ditch effort). Possibly something got screwed up and corrupted something in the windows installation. Just my 2 cents before you RMA the card.
  11. I did a fresh reinstall of 11.9 a couple of times and downloaded 11.10 and 11.8 and it seems that reinstalling 11.8 does the trick, for now it seems to have solved the issue! Thanks for all the input guys, seems like I don't have to RMA the card just yet :)
  12. So uninstall the video drivers. Use driver sweeper. Reboot the PC.
    Install the 11.9 drivers, now ignore windows update, whenever it tells you to update the video drivers ignore it.
  13. Oh I missunderstood, sorry about that.
  14. ..........................................
Ask a new question

Read More

Radeon GPUs Graphics