Sign in with
Sign up | Sign in
Your question

6950/display driver crashing in DX11 games

Last response: in Graphics & Displays
Share
October 3, 2011 7:40:14 PM

Several months ago, I built my brother a new computer. Until recently, he has only played DX9-10 titles, installing The Witcher 2 just days ago. No other games have given him any problems or crashes, except for the occasional Fallout 3 bug.

He has been able to play The Witcher 2 for less than an hour at most, and whenever he loads a saved file, the game freezes and he is greeted with a "Display driver stopped responding and has recovered" error. This also happens now when the tutorial or new game is started. To see if this may be DX 11 related, I installed the DX 11 patch + textures for Crysis 2. With DX11 disabled, the game runs flawlessly. Enabling DX11 causes the same exact problem with Crysis 2. Fallout 3, Mass Effect 2, Dragon Age, and others run fine. FurMark also seems to be OK (I only looked/ran for a minute, but no crashes occurred during this time).

Before trying Crysis 2 in DX11, I first thought that this was a new driver issue, as I installed the 11.9 CCC right before he started playing. I uninstalled 11.9 and tried 11.8, same thing. 11.7, same thing. I then went back to 11.3, same thing. I then thought it may have something to do with the fact that I flashed his 6950 to a 6970 BIOS, and maybe the voltages were off. I turned them up to the 6970's default voltages, same thing. I then flashed back to the original 6950 bios, same thing. What is also strange is that, at one point, I tried uninstalling the CCC through the default Windows uninstaller, and it gave me an error. After navigating to the AMD folder and launching the uninstaller through there, it gave me an error and then a blue screen (copied below). It also looked like he may have had multiple drivers installed, as there were several different CCC packages in his main AMD directory. Since then, I used the Windows Install Clean-Up Utility to get rid of any AMD programs he had, and used the newest Driver Sweeper in Safe Mode to clean any of the remainders. He is currently running 11.9, though the CCC installer did finish with a warning that stated another driver, package, or something was found on the computer. Where it may have been located, I have no idea (manually deleted the Program Files/Program Files X86/C:\AMD directories as well).

Does anyone know what the problem may be? Does this seem like a DirectX 11 issue? Temperatures are fine. This is has been pretty tough to figure out.

ASRock P67 Extreme4
i5-2600K
HIS Radeon 6950
8 GB RAM
Windows 7 64-bit SP1 + all updates
Corsair 750W PSU

Problem signature:
Problem Event Name: BlueScreen
OS Version: 6.1.7601.2.1.0.768.3
Locale ID: 1033

Additional information about the problem:
BCCode: 116
BCP1: FFFFFA800727A390
BCP2: FFFFF880098743BC
BCP3: 0000000000000000
BCP4: 0000000000000002
OS Version: 6_1_7601
Service Pack: 1_0
Product: 768_1


EDIT: I also tried running The Witcher 2 on the lowest settings, and the same problem occurs, but I'm not sure if the lowest settings necessarily disable DX11 if someone has a DX11-capable card.

EDIT 2: I flashed the motherboard's BIOS to the latest one, but still no luck. I did manage to run The Witcher 2 for about a minute before quitting, thinking that I solved the problem. But after quitting the game and reloading, same thing again.
a c 143 U Graphics card
October 3, 2011 8:28:26 PM

the "Display driver stopped responding and has recovered" error is a bug related to MS windows that has been happening with both AMD/nVidia GPUs since the windows vista appeared.
it might happen because of a drivers issue, or the GPU is overclocked and crashes and it happend a lot with AMD 5K series when the GPUs were on IDLE mode (cuz win7 reduces voltage too much dues to power savings options)
try this as it could help
http://support.amd.com/us/kbarticles/Pages/737-27116Rad...
http://answers.microsoft.com/en-us/windows/forum/window...

for the game crashing things, till now i'm not able to play Crysis 2 DX11 cuz it freezes a lot, after i did a hard search it was because it's illegal copy and the 1.9 patch is the main cause...
but for the rest of DX11 games (Deus Ex HR, Metro 2033, BFBC2) all run just fine without any issues, try more DX9 games such as Mafia ii, AC, Far Cry 2 and see what happens, if it's still crashing so it might be because of the drivers swapping issue.

i would try to install a fresh copy of Win7 with the latest 11.9 CCC drivers and give it a try. Also check temperatures of the GPU and see if it's related to a heat issue
m
0
l
October 3, 2011 9:20:45 PM

Thanks for the reply. I am looking over those links.

At this point, I'm trying to avoid a fresh Windows install. Like I said earlier, it's not a temperature issue; they're good. Neither the GPU nor CPU are overclocked and I'm using the original BIOS as I'm troubleshooting this.
m
0
l
Related resources
a c 143 U Graphics card
October 3, 2011 9:22:44 PM

ok, do whatever you have to do and keep me informed
m
0
l
October 3, 2011 9:39:31 PM

I updated some motherboard drivers and re-installed DirectX. Did not fix anything. It's a strange problem in that The Witcher 2 seems to usually crash, but there are times when I could keep playing and it's fine.

I don't really own enough DX11 titles to test whether or not this is truly DX11-related, but the only games that crash are DX11 games.

I've had this error occur with my own 5870, but it was always driver-related. I could not use any driver except 10.4 until 10.10, then 11.2, then 11.4, and now 11.9; every other crashed randomly like this, but it was always random. This is in DX11 games, never in Windows.
m
0
l
a c 143 U Graphics card
October 3, 2011 9:46:37 PM

after i read about the drivers swapping you did, and some packages aren't removable i still recommend a clean install of updated Win7 and bumping up more games to test
m
0
l
October 3, 2011 9:47:40 PM

Does your brother have any image mounting software installed? Daemon tools etc. I got this error after installing Mass Effect 2 and closing it solved the problem for me
m
0
l
October 3, 2011 11:00:56 PM

There are no image-mounting programs on his computer. I agree that I should try out some more games on his computer; it's just too bad that I don't have any other DX11 titles to try.
m
0
l
October 4, 2011 1:56:54 AM

I ran the Civilization V demo (DX11 option enabled) for about one minute three times. No crashes once a game actually starts. I then installed my copy of Metro 2033 (DX11) and it crashed right when the 3D menu popped up.

EDIT: I also uninstalled the 11.9 drivers one more time, cleaned everything AMD/ATI through the regular uninstaller (no problems), the Windows Install Clean-Up Utility, and Driver Sweeper in Safe Mode. I installed the 11.6 CCC package, no problems, no warnings or error messages. Same problem persists.

Does anyone else think that this is DX11 related? Could it be the card itself?
m
0
l
a c 143 U Graphics card
October 4, 2011 1:58:51 AM

install a fresh win7, that's ill make us identify the problem..... Also what is the model of your PSU ?
m
0
l
a c 143 U Graphics card
October 4, 2011 3:44:33 AM

PSU is great, make sure to back up everything before you format.
Also, if you disable DX11 so you're running in DX9 mode, no need to get DX9 games but you need to get some to test stability
we can't confirm whether it's the GPU or the Drivers we need to check up the OS, driver first then judge.
m
0
l
October 6, 2011 2:22:57 PM

How do I disable DX11 on the 6950? I have not seen such an option in The Witcher 2 or in Metro 2033. Would I be able to do it through the CCC or another program?
m
0
l
a c 143 U Graphics card
October 6, 2011 2:24:56 PM

you do it through the game. eg. Metro 2033 in the Video Menu you'll find DirecX 11 enable or disable it. Crysis 2 you'll get to choose between DX11/9
m
0
l
!