Sign in with
Sign up | Sign in
Your question

[Solved] XFX 6870 not showing full screen in games (black borders)

Last response: in Graphics & Displays
Share
October 3, 2011 11:23:09 PM

I recently installed a Radeon 6870 and it works great. The only problem is that when I play games, the screen has a border around it and the image looks a little fuzzy (not much but noticeable). Outside of games, I have the scaling options set to where the screen is showing the entire display on my monitor (no black borders outside of games). I'm not sure why but for some reason, CCC must be losing its scaling configuration only while playing games. When I alt-tab out of a game, the scaling is correctly placed. :-/
October 4, 2011 3:46:59 AM

I have the same problem but only while using a dvi or hdmi signal . When i use an adapter and use VGA i don't have that same issue. I suspect it has to do with the video drivers but i could be wrong.
m
0
l
October 4, 2011 11:59:13 AM

Do you have your monitor installed the right way. What does ccc says about the monitor. I had this problem because of faulty monitor drivers, it switched also back from 60 hz to 50 hz.
m
0
l
Related resources
October 4, 2011 12:09:07 PM

Full screen 3d generally uses different rules for monitor scaling, I'd see if your monitor has scaling options, if there is a second set of 3d options(I don't currently have any AMD cards so I cant check) or if your game can be set to the native resolution of the monitor
m
0
l
October 14, 2011 4:42:15 AM

Okay, so I thought I would post an update to the problem that I was having. It seems that I found a fix albeit a bit of a hassle.

It seems that when running a Radeon 6000 series graphics card, many people are having issues with a black border around all edges of the screen when running games like Crysis and other games that aren't DX11 natively. The fix is this: Alt + Enter until your screen changes to completely full screen. I found this solution on another forum recently and thought I would share in case others need a solution to this problem later on.

I'm not sure what is causing it and this is no permanent solution by any means, but it seems to work. It only takes a few seconds to adjust the display using Alt + Enter and your good to go. It had nothing to do with the scaling properties and as many online on other forums have mentioned, complete reinstallation of all of the various versions of AMD drivers did not work. Also, some were saying that it could possibly have something to do with what monitor you are using.

Hopefully this info will help someone who has this problem. ;) 

Edit: I also forgot to mention that it seems that changing the input cable from HDMI to DVI fixes the problem completely. I'm using HDMI. The only bad thing about using DVI is that you may not get HDMI quality video if you use your computer for Blu-Ray 1080p movies. I don't have a blu-ray player installed so I may end up using DVI if I feel like it later on. XD
m
0
l
October 14, 2011 5:53:37 AM

i had the same issue when i play any of the crysis games. i fould with crysis 2 that hitting the alt+enter doesnt always work. but, what works for me is to disable full screen, apply and exit the game. start the game back up (windowed mode) enable full screen and apply. shazam! full screen. although, you have to make sure to disable full screen before you exit, or have to do the two step proccess again. with warhead, i can't get the boarder to go away.... kind of annoying. also, whats weird to me is that i can play crysis 2 on ultra settings with dx 11 and high texture settings with out a hickup. but running warhead on the highest settings gives my computer grief...?
m
0
l
!