Solved

Asus A73SV Network Controller (Not on their site)

Hello,
I have an Asus A73SV laptop that I recently reformatted because the bloatware finally just made me mad enough to do it.

I didn't back up my drivers but I have most of them downloaded from the Asus support page (I have the LAN driver and a few others that are allowing me to use the internet)

Well I tried to download the Wireless driver and it says that it cant find the Network Controller, and I can't find it on their website.

I have been looking around, doing research, etc, and people always seem to need the motherboard name etc. Well Asus (and other sites) don't have the motherboard listed in the specifications and I don't know what to do.
11 answers Last reply Best Answer
More about asus a73sv network controller site
  1. Hi,
    have you checked under Utilities?
    There are some Wireless applications there (Wireless Switch and Wireless Display).
  2. I hadn't downloaded the Wireless Display one, but I already had the Wireless Switch

    But now I downloaded the Wireless Display, restarted the laptop, and still nothing
  3. What driver have you installed, Intel or Azu?
  4. The Intel one. Called "Intel WiFi Wireless LAN Driver"
  5. Try uninstalling the Intel one, restart and install the Azurewave.
  6. Alright, uninstalled the Intel one, restarted, and attempted to install the Azureware one.

    While installing it, it pops up with a "Installing Drive for Qualcomm Atheros Wireless Network Adapter". Then after a while, an error comes up and the header says "Qualcomm Atheros 802.11a/b/g/n wireless Adapter" and the error says "Device may not be present of could have been ejected/unplugged from the system. Insert or Reinsert now."

    My wireless is turned on, if that is what it might be (or at least the light that indicates my wireless is turned on, is lit up)

    :\
  7. Then it's an Intel adapter. Try reinstalling again the Intel driver. There are several options listed there. Try each of them.
  8. You mean the different Intel drivers? Or each option on that specific driver? Because when I opened it up, I couldn't open any of the options on that driver I had before because it kept saying I didn't have an adapter or something
  9. Best answer
    I mean that on the ASUS download page 3 different Intel drivers are listed. I would try each of them.
  10. Sorry, been on a business trip.
    It finally worked! Took your advice and downloaded all the drivers
    For anyone that might have the same problem,
    I have an Asus A73SV and the driver that worked was "Azurewave NE155 Wireless Lan Driver and Application"
  11. Best answer selected by Guntrigger.
Ask a new question

Read More

Motherboards Asus Network Controller