Sabertooth Z77 RAM Booting Problem. Please help.

Hi there,

I recently bought a Sabertooth Z77 motherboard and some Corsair TW3X4G1333C9A RAM.

I have tried every combination of slots possible but I can't seem to boot or post at all. The DRAM LED light is always lit, when I hold it, it begins to flash and the system restarts. When it starts again the led begins flashing quickly until it goes solid, again.

Am I doing anything wrong here?

Thanks in advanced.
1 answer Last reply
More about sabertooth booting problem help
  1. Try pushing down the RAM really hard into the motherboard until you hear it grind. And use slot 1 for starters.
    I went nuts over it too. I had Corsair Vengeance 2 x 8GB. Didn't work in any way.
    Then I thought it was unsupported and went out and bought 2x4GB Corsair Vengeance RAM. Plugged that in and didn't work.
    Then packed the new 4GB ones to be returned to the store.
    Funny thing is I put one 8GB in and pushed it down really hard until I heard it sink in and bite and then I started it up. Got one click and three beeps and I was like oh shit... only the dram light was off. Some problem with the fan plugs and I didn't have a keyboard plugged in.... it worked.
Ask a new question

Read More

Motherboards Sabertooth RAM LED Monitor