Sign-in / Sign-up
Your question

ASRock z77 extreme6 - Slow LAN

Tags:
  • Motherboards
  • LAN
  • ASrock
Last response: in Motherboards
January 11, 2013 12:10:43 AM

Hey everyone. Just built a new machine with the mentioned MoBo and I have horrible download/upload speeds. If I plug my old system back in which had an Asus Sabertooth x58 - everything is fine.

I updated the broadcom driver from ASRock's website - no change. I also tried installing their XFast LAN thing - no change. Any recommendations for what to try next?

More about : asrock z77 extreme6 slow lan

a b V Motherboard
January 11, 2013 12:23:31 AM

XFast LAN actually signicantly slowed down my friend's internet speeds. I would uninstall, restart, then run a registery checker.
m
0
l
January 12, 2013 1:20:21 AM

I removed it and ran ccleaner after a reboot. Saw no change. I went ahead and reinstalled Windows 8 since I hadnt done much on the new machine yet. Still slow.

CCleaner, for instance, took about 2 minutes to download, its 4MB. On my old rig, I tested downloading it and it was done in about 10 seconds.

As I navigate to web pages, it takes forever for the contents to load.
m
0
l
Related resources
January 25, 2013 1:44:03 AM

y2hbk, I have the same issue. I'm on a 10 meg down connection and get 11 to 11.5 with same cable on another computer.
I get .82 to 1 meg down with this new Extream4 mobo. Freaking sad...

Did you ever find a resolve for this?

Thanks,
John
m
0
l
January 25, 2013 2:29:31 AM

OK guys I solved the slow lan speed issue. Following is what I did. Simple really...

One may have nothing to do with the other but wow...

First I went into the Extreem4 bios and changed the setting in the OC area at the bottom underneath where it shows the ram timing, form Auto to XMP.

Then I uninstalled the XLan Fast program.

Wow... my computer itself is lightning fast now (MUCH faster than it was) and my download speeds are right up there with the other computers in my home.

Do these two things if you have an Extream4 and you will be glad you did.

Also, if you run across someone else having the same issues, please pay it forward and either tell them how to fix it or point them to this thread.

Thank you,,
John
m
1
l
July 13, 2013 6:35:47 PM

Just want to add...I had a similar issued caused by xfast lan...not sure how or why but removing it resolved the issue completely
m
0
l
January 21, 2015 9:20:33 AM

Hello people. I just wanted to give a suggestion. Something that worked magic. On the XFast LAN popup window that appears on the right bottom corner, I right clicked and selected the option "Calibrate Line" under "Traffic Shaping" option. Then everything worked fine. No more speed caps. I guess, this is something that ASRock XFast LAN needs. Anyway, worked for me. In case, you wanna find a simple solution, this is what I'd suggest.

Cheers.

Note: If this doesn't work, then I'd refer to the answers above. Also, this was a solution on ASRock X79 Extreme 9
m
2
l
January 26, 2015 4:25:32 AM

Sunny Sawrav said:
Hello people. I just wanted to give a suggestion. Something that worked magic. On the XFast LAN popup window that appears on the right bottom corner, I right clicked and selected the option "Calibrate Line" under "Traffic Shaping" option. Then everything worked fine. No more speed caps. I guess, this is something that ASRock XFast LAN needs. Anyway, worked for me. In case, you wanna find a simple solution, this is what I'd suggest.

Cheers.

Note: If this doesn't work, then I'd refer to the answers above. Also, this was a solution on ASRock X79 Extreme 9


OMG it actually worked, thanks :D 
m
0
l
October 17, 2015 3:57:54 AM

Sunny Sawrav said:
Hello people. I just wanted to give a suggestion. Something that worked magic. On the XFast LAN popup window that appears on the right bottom corner, I right clicked and selected the option "Calibrate Line" under "Traffic Shaping" option. Then everything worked fine. No more speed caps. I guess, this is something that ASRock XFast LAN needs. Anyway, worked for me. In case, you wanna find a simple solution, this is what I'd suggest.

Cheers.

Note: If this doesn't work, then I'd refer to the answers above. Also, this was a solution on ASRock X79 Extreme 9


Ditto worked for me.

Whew!

m
0
l
a c 86 V Motherboard
July 26, 2016 3:07:42 AM

me too :p 
m
0
l