Sign in with
Sign up | Sign in
Your question

My Laptop's not getting charged when its ON :(

Last response: in Components
Share
March 6, 2012 12:16:01 PM

I have an Acer Aspire 4736z laptop and it does not charge when its ON, but when its Shut down then it charges (occasionally it does not even when its Shut Down) i have a snapshot of the Charging error thing as a small symbol appears like a little thunderbolt above the plug symbol...? Please Help me as i am unable to use my laptop at all as i have to turn off the laptop in order to charge the battery and it happens mostly when i am having important work :(  ;( :fou:  :pfff: 

More about : laptop charged

a c 139 ) Power supply
a c 572 D Laptop
March 6, 2012 12:17:48 PM

How old is your battery?
m
0
l
March 6, 2012 2:47:06 PM

Are you certain that you have the correct power brick? (AC Adapter)? These can be easily misplaced when working with other laptops around and just because the plug fits doesnt mean that the voltages/amps are correct!

Also try to simply re-seat the battery and see what happens.

Does the laptop work/run if you plug in the AC Adapter with the battery removed? But like WR2 mentioned, if its old it could be part of the problem. When you charge the laptop with the battery unplugged, does it last a reasonable amount of time or does it drain very quickly? this could mean that the problem is simply the battery but if it does last, i've seen this exact same thing happen many times with people grabbing the wrong power adapter. (I've even had a work laptop and the AC Adapter from another Dell model would work and charge the battery but it would slowly drain even when plugged in when the power was on because the voltage was low
m
0
l
Related resources
March 15, 2012 8:18:31 PM

I guess hardly a year and a half, but i hardly used the laptop... if someone sees it you can say its just three months old... everything is new... i will tell you the amazing part when i went to the Service point of Acer the laptop was charging and it was with the same power cable and the adaptor as well... but once i come back home its the same... The service point guy guessed it to be some problem on the board and might cost 240$ to get it fixed... i am very sure he is trying to cheat me... why would the laptop get charged in the service point and not at my home even after several trials to see whether the problem is coming still i failed to prove there was a problem.. but as soon as i come back home it acts weird and starts to show me the middle finger :( ... ill attach a snapshot for better understanding...
The laptop runs when its either shut down or when i try to run it on the main power supply but without the battery...but i dont see an option to attach a snapshot :( 

m
0
l
March 15, 2012 8:41:11 PM

Dude ive done everything possible even before posting my issue over here... The Laptop works fine when i plug in the AC adapter with the battery removed... i am using a correct power adapter which was supplied with the laptop... Just read my reply to WR2


" I guess hardly a year and a half, but i hardly used the laptop... if someone sees it you can say its just three months old... everything is new... i will tell you the amazing part when i went to the Service point of Acer the laptop was charging and it was with the same power cable and the adaptor as well... but once i come back home its the same... The service point guy guessed it to be some problem on the board and might cost 240$ to get it fixed... i am very sure he is trying to cheat me... why would the laptop get charged in the service point and not at my home even after several trials to see whether the problem is coming still i failed to prove there was a problem.. but as soon as i come back home it acts weird and starts to show me the middle finger :( ... ill attach a snapshot for better understanding...
The laptop runs when its either shut down or when i try to run it on the main power supply but without the battery...but i dont see an option to attach a snapshot :(  "
m
0
l
!