ATI/AMD Radeon HD 6870

Hi all this is my first post here and I'm having a problem. I bought a PC through Cyberpower (the Black Pearl build). Heres the setup.

CASE: * Azza Hurrican 2000 Full Tower Gaming Case with 4 Hot Swappable HDD Cage & (4) 230MM Fans
CD: 24X Double Layer Dual Format DVD+-R/+-RW + CD-R/RW Drive (BLACK COLOR)
CPU: Intel® Core™ i7-960 3.20 GHz 8M Intel Smart Cache LGA1366
CS_FAN: Maximum Enermax 120MM Case Cooling Fans for selected case (Maximum Silent Operation) (500-1,200 RPM T.B. Silence Black Color with Blue LED Twister Bearing 8-14 dBA ])
FAN: Asetek 510LC Liquid Cooling System 120MM Radiator & Fan (Enhanced Cooling Performance + Extreme Silent at 20dBA) (Single Enermax Enlobal Silent High Performance 120MM Fan)
FLASHMEDIA: INTERNAL 12in1 Flash Media Reader/Writer (BLACK COLOR)
FREEBIE_CU1: FREE! Killer Xeno Pro Gigabit High Speed Online Gaming PCI Network Interface Card
HDD: 1TB SATA-III 6.0Gb/s 32MB Cache 7200RPM HDD (Single Hard Drive)
MEMORY: 12GB (2GBx6) DDR3/1600MHz Triple Channel Memory Module (Kingston HyperX)
MONITOR: * 24" Widescreen 1920x1080 Asus VH242H LCD w/ Built-in Speaker, DVI, & HDMI
MOTHERBOARD: (3-Way SLI Support) EVGA X58 SLI™ 3 Intel X58 Chipset SLI/CrossFireX Triple-Channel DDR3/1600+ ATX Mainboard w/ 7.1 HD Audio, GbLAN, USB3.0, 2 x SATA-III, RAID, 3 Gen2 PCIe, 2 PCIe X1 & 1 PCI
MULTIVIEW: Non-SLI/Non-CrossFireX Mode Supports Multiple Monitors
NETWORK: Onboard Gigabit LAN Network OS: * Microsoft® Windows 7 Home Premium (64-bit Edition)
POWERSUPPLY: 800 Watts - XtremeGear Gaming Power Supply - Quad SLI Ready
SOUND: * Asus Xonar DS 7.1 Channels 24-bit 192KHz PCI Audio Card
USB: Built-in USB 2.0 Ports
VIDEO: AMD Radeon HD 6870 1GB GDDR5 16X PCIe Video Card (Major Brand Powered by AMD)

The problem that I am having is artifacting / freezing / some weird things with screen getting split up (next time it happens ill screen shot it) / and a few blue screens stating problem with display driver. I thought it was card so I got a new one from CyberPower at their expense and for a while it was fine. But yesterday it happened again with I was doing some stress tests/ benchmarks. I thought it was the drivers and used driversweeper to uninstall and then reinstall. Same problem. Also when I ran 3dmark 11; my results weren't that great I would top out at 28 fps and average 24 fps. That is terrible compared to similar builds. I have updated everything to my knowledge and by no means am I a hardware expert. Any advice on something would be great maybe its a compatibility issue with the card and this is the only problem I have. Thanks guys any responses are greatly appreciated.
13 answers Last reply
More about radeon 6870
  1. That the replacing the card fixed it for a while points to the card being the culprit again but what is causing it PSU or Motherboard?
  2. I don't see it being the PSU, I would say the motherboard I guess. Every now and then throughout the past month it would crash (go to black screen) and lock up so I would have to manually power off and restart. I didn't run any games that would put much stress on the card , just TF2 for the time being so I don't know if my card has been underperforming this whole time. I mainly got this build for upcoming winter games like battlefield, skyrim, and so forth. I played around with the drivers by uninstalling them multiple times using driversweeper and it would bug out still once in a while. The time that it happens the most though is when I'm loading up a video that uses adobe flash. When I noticed that I turned off hardware acceleration on adobe, but I haven't noticed a difference as it is still doing it.
  3. If you still have their warranty why don't you let them deal with it.
  4. Well I have called them and waiting on a response. Just didn't know if anyone else has heard of this problem and was hoping for a fix without shipping whole system back across the country.
  5. I understand the problem off shipping cross country but to me the only reason for buying from them is not having to tinker with issues like you are having. Therefore I buy the parts and build myself to save my money plus I ensure I am buying quality parts, some of they parts listed for their builds I would never buy your PSU http://forums.steampowered.com/forums/showthread.php?t=1589675
  6. Awesome, lol. Well time to swap out PSU. What would you recommend?
  7. Seasonic, Antec or Corsair are amongst the most recommended PSU's!
  8. Ok, I'll look into them. But in the mean time if anyone has had this happen to them most notably the display screen splitting, please let me know
  9. linkv2 said:
    Ok, I'll look into them. But in the mean time if anyone has had this happen to them most notably the display screen splitting, please let me know



    I just got the black pearl as well for christmas and am having the exact same issue did replacing the power supply fixc your problem?
  10. xjumpmanx said:
    I just got the black pearl as well for christmas and am having the exact same issue did replacing the power supply fixc your problem?


    I just sent the whole system back to cyber power and they fixed it.it was a bad gfx card. the only thing was is that I went through 3 gfx cards before it worked. At their cost ofcourse. Just send for a new card and good luck.
  11. linkv2 said:
    I just sent the whole system back to cyber power and they fixed it.it was a bad gfx card. the only thing was is that I went through 3 gfx cards before it worked. At their cost ofcourse. Just send for a new card and good luck.



    I just threw in a corsair 700 watt Power Supply.
  12. xjumpmanx said:
    I just threw in a corsair 700 watt Power Supply.


    Did it fix it?
  13. My issue was so random. It would do the split screen thing at random times and sometimes it would boot with the screens bottom on the top. I literally just got it all back and up running at 9:40 Pm eastern time. So we shall see after it runs for awhile.

    xJumpManx
Ask a new question

Read More

Radeon Graphics