Sign in with
Sign up | Sign in
Your question
Solved

Crossfire Issues - Diamond Radeon HD 4670 x 2

Last response: in Graphics & Displays
Share
October 6, 2011 6:55:11 PM

I recently installed two Diamond Radeon HD 4670 cards in my case, but they don't seem to work. After numerous configurations (replacing the cards, moving the Crossfire Bridge, installing new drivers and software, etc), nothing seems to work and the Catalyst Control Center continues to state "The Crossfire internal bridge interconnects linking your crossfire graphics cards are not properly connected. Both bridge interconnects must be attached."

To my knowledge, everything is connected properly and the equipment isn't defective. Do these graphics cards require two bridges? Any and all input is welcome.

System Specs:

HAF X Coolermaster Case
Gigabyte GA-Z68X-UD3H-B3 Motherboard
2x4GB Patriot G2 DDR3
Intel i5 2500K 3.3Ghz Processor
OCZ ModXStream-Pro 600W Modular PSU
2 x Diamond Radeon HD 4670 1 GB DDR3 GPU

Best solution

October 6, 2011 7:20:16 PM

Did you check your BIOS settings to enable Crossfire?

http://www.overclockers.com/gigabyte-z68xud3hb3/

This article says you can't have Turbo USB3.0 enabled and do Crossfire, so you need to disable it.
Share
a c 143 U Graphics card
October 6, 2011 7:23:26 PM

jjhuang42 said:
Did you check your BIOS settings to enable Crossfire?

http://www.overclockers.com/gigabyte-z68xud3hb3/

This article says you can't have Turbo USB3.0 enabled and do Crossfire, so you need to disable it.

good tip to mention, but it has nothing to do with the hardware configuration.
m
0
l
Related resources
a c 143 U Graphics card
October 6, 2011 7:24:25 PM

@ OP, try changing the CF bridge, and test each card individually and check if you have a faulty one.
m
0
l
a b U Graphics card
October 6, 2011 7:29:58 PM

Are you using the bridge that's closest to the VGA/DVI ports (e.g. back of the case)?
m
0
l
October 6, 2011 7:34:01 PM

Well, according to his post, he indicated he tried swapping out the cards and moving the bridge, so I ruled out hardware failures. The only things hardware wise that I could think of are bad bridge or a bad MB. I looked for a zero cost solution first.

He said he tried configuring the Crossfire software, so I went back to problems with BIOS. Numerous articles/posts online indicate Gigabyte's implementation of Turbo USB3.0 interferes with the 16x PCIe slot, that is if Turbo is enabled, it will make the single GPU work only at 8x, and Crossfire not at all.
m
0
l
a b U Graphics card
October 6, 2011 7:47:46 PM

Check the under side of your crossfire bridge and look for labels near the connectors denoting 1 and 2. Mine says "J1A" and "J2A" for example. Make sure J1A is on the top card and J2A is on the bottom card.
m
0
l
October 7, 2011 1:24:04 AM

Thanks for the referral article - I appreciate the information. I'll take a look at the BIOS and see if this is the problem.

jjhuang42 said:
Did you check your BIOS settings to enable Crossfire?

http://www.overclockers.com/gigabyte-z68xud3hb3/

This article says you can't have Turbo USB3.0 enabled and do Crossfire, so you need to disable it.

m
0
l
October 7, 2011 1:25:50 AM

Thanks for the suggestion, but I believe I've ruled out the GPUs being faulty. I'll double check though if other solutions do not work.

ilysaml said:
@ OP, try changing the CF bridge, and test each card individually and check if you have a faulty one.

m
0
l
October 7, 2011 1:28:28 AM

At the moment, the bridge is plugged into the first "bridge slot". So where you mentioned.

In the initial post though, I've tried different configurations with the bridge in different places. I've wondered though, does the bridge placement matter? From what I've read I thought it didn't? (Could be wrong though)

borisof007 said:
Are you using the bridge that's closest to the VGA/DVI ports (e.g. back of the case)?

m
0
l
October 7, 2011 1:49:10 AM

I went through BIOS, modified some additional pieces of hardware, and now it seems to be functioning! Thanks for the idea about BIOS - wouldn't have ever guessed that would be the problem.

jjhuang42 said:
Did you check your BIOS settings to enable Crossfire?

http://www.overclockers.com/gigabyte-z68xud3hb3/

This article says you can't have Turbo USB3.0 enabled and do Crossfire, so you need to disable it.

m
0
l
October 11, 2011 6:07:53 PM

You don't have to connect two bridge interconnects in order to use crossfire. It's only required one bridge interconnect for two cards. Please make sure the two graphics cards are identical NOT mixed matched from their PCB design. Also, make sure to use the latest drivers 11.9 via AMD's website that will help. Good Luck!

Best Regards,
DiamondMM's Tech


greyhaven said:
I recently installed two Diamond Radeon HD 4670 cards in my case, but they don't seem to work. After numerous configurations (replacing the cards, moving the Crossfire Bridge, installing new drivers and software, etc), nothing seems to work and the Catalyst Control Center continues to state "The Crossfire internal bridge interconnects linking your crossfire graphics cards are not properly connected. Both bridge interconnects must be attached."

To my knowledge, everything is connected properly and the equipment isn't defective. Do these graphics cards require two bridges? Any and all input is welcome.

System Specs:

HAF X Coolermaster Case
Gigabyte GA-Z68X-UD3H-B3 Motherboard
2x4GB Patriot G2 DDR3
Intel i5 2500K 3.3Ghz Processor
OCZ ModXStream-Pro 600W Modular PSU
2 x Diamond Radeon HD 4670 1 GB DDR3 GPU
m
0
l
October 11, 2011 10:44:20 PM

Best answer selected by greyhaven.
m
0
l
!