Sign in with
Sign up | Sign in
Your question

Asrock fm2a75m-itx no video signal

Last response: in Motherboards
Share
January 11, 2013 5:58:00 PM

Hi -

I just built a computer with this motherboard and an AMD a8-5600K 3.6G 4M FM2 R CPU, and I cannot get it to display video signal by either VGA or HDMI to a TV.

I tried using VGA to a PC monitor, with no luck.

The computer powers on and the CPU fan spins and the case LED lights function, but no video signal.

I tried reinstalling ram sticks, using single sticks, etc.

I tried booting with all unnecessary components disconnected except for power switch, ATX power, and CPU fan.

I tried booting with the front case audio connected and headphones plugged in and no ram to see if the mobo would beep at me, and heard nothing.

Is the board fried? Anything else I can do?
Please help!
a c 114 à CPUs
a c 559 V Motherboard
January 12, 2013 4:24:52 AM

Hi
is there a case speaker (beeper) connected to the motherboard?
m
0
l
January 12, 2013 12:34:55 PM

alexoiu said:
Hi
is there a case speaker (beeper) connected to the motherboard?


No, the speaker doesn't have a case. That's why I tried using the headphones with the hd_audio (front case audio) plug connected to the MB.

m
0
l
Related resources
a c 114 à CPUs
a c 559 V Motherboard
January 12, 2013 1:04:36 PM

The headphones do not work for troubleshooting. You need something like http://www.newegg.com/Product/Product.aspx?Item=N82E168... connected to the motherboard (the front panel connector, where you plug the wires from the power, reset switches, HDD led...)
m
0
l
January 12, 2013 1:43:27 PM

alexoiu said:
The headphones do not work for troubleshooting. You need something like http://www.newegg.com/Product/Product.aspx?Item=N82E168... connected to the motherboard (the front panel connector, where you plug the wires from the power, reset switches, HDD led...)


Thanks for the info. Based on the info present though, is there anything else I should try, or should I get a replacement motherboard? Or could it be the CPU???

m
0
l
a c 114 à CPUs
a c 559 V Motherboard
January 12, 2013 4:25:35 PM

Motherboard or CPU. Hard to say.
m
0
l
January 24, 2013 8:26:15 PM

I just tried it with a replacement motherboard and have the exact same problem...

Should I get a replacement CPU, or try a different brand of ram???

:-(
m
0
l
January 24, 2013 8:27:12 PM

I noticed neither the RAM I have, nor the CPU, are on the list of supported parts on ASrock's website for this board, although they meet the proper specs...
m
0
l
!