"Not enough space in Runtime area"


I'm building a new PC and i'm having some problems with the motherboard. Everything seems fine upon boot up, but then i get the following message:

Not enough space in Runtime area!!. SMBIOS data will not be available.
Press F1 to Resume

I can press F1 and continue to Windows installation (i can't install windows as the HDD i'm using seems to be broken: Windows (i've tried both Vista and 8) refuses to copy all the necessary files over and returns various errors, but i believe this is unrelated to the Runtime error as i get it without the HDD attached).

I've tried booting with minimum components attached, different memory etc and discovered it seems to be down to the keyboard being plugged. If there's a keyboard plugged in (whether an MS Wireless Multimedia USB keyboard or old Compaq PS/2 one) the error occurs. Without either the USB or PS/2 keyboard, no error.

I've reset the CMOS jumpers, removed the CMOS battery for an hour, updated to the latest BIOS to no avail.

Assuming the HDD problems i'm having are unrelated and i can install Windows on a new HDD i plan on purchasing, then this isn't a massive problem. But obviously i don't want to have to keep pressing F1 every time i turn the PC on, to get into Windows. And obviously i don't want to have to unplug the keyboard to prevent the error, every time i turn the PC on!

My spec is below, does anybody have any ideas please?

Thanks in advance.

ASRock 970DE3/U3S3 Motherboard
AMD Bulldozer FX-6100 (FD6100WMGUSBX)
VTX3D AMD Radeon HD 7750 Graphics Card
Corsair Vengeance 1866MHz CL10 DDR3 (2x 8gb - CMZ16GX3M2A1866C10R)
Ace Black Edition 650W PSU
4 answers Last reply
More about space runtime area
  1. Nobody?
  2. I am having this error too. but no idea how to fix that :S
  3. Use the original AMI BIOS Flash Tool "AFUWIN" there make hook all on the left side Block options. This will erase the NVRAM and all is fine!!!
    dont forget to load the asrock bios file
  4. Eu estava com este problema em minha placa mãe ASROCK N68C-GS FX. baixei a BIOS mais nova para DOS. PS. não usei a atualização direta para windows do site. Baixei o AFUWIN 4.48 de outro site, onde tive a opção BLOCK OPTIONS lá selecionei (program All Blocks, Main BIOS Image, Boot Block, NVRAM) aí é só mandar buscar o arquivo da BIOS baixado para DOS (descompactado) detalhe *mandar exibir todos arquivos. clicar FLASH e aguardar o termino. sair e reiniciar o PC. e boas.. seus problemas acabaram.

    abraços a todos.
Ask a new question

Read More

ASRock Runtime Motherboards