USBs and Display not working

Firstly, I'd like to thank you all for your time, now, to the problem: I just installed a new mobo, CPU and Graphics card. All my case fans as well as the CPU and GPU fans all are running. The mobo is lighting up. The disc drive is opening and closing etc. But for some reason the USBs and display are not working. Nothing I plug into the USBs work... My phone charger, my keyboard and mouse etc. None of them work. I've tried multiple mouses and none work. The display is receiving no signal. Please help, I have no idea what is wrong...
8 answers Last reply
More about usbs display working
  1. Jake
    You need to list the make and model of components so people can help you, we can't guess what you are working with.
  2. Sorry, I forgot to list that. My gear is:

    CPU: i5-3570k ivy bridge LGA1155
    Motherboard: Asus P8Z77-V LK
    Graphics Card: Gigabyte Geforce GTX 660ti
  3. Remove graphics card and connect monitor to motherboard then try to boot system, you also forgot to list power supply, HDD or SSD, optical drive, case and fans, keyboard and mouse.
  4. PSU: Antec Earthwatts 750w
    Mouse: Logitech M500 (I've tried other mouses and it didnt work too)
    Keyboard: Logitech G110
    HDD: Seagate Barracuda 3000GB and Seagate Barracuda 250GB
    Case: Antec 1200
    All the fans are ones that came with the case.
    The optical drive is just some basic LG Writer

    Keep in mind that all these things worked with my last mobo, graphics card and cpu. I'll try your suggestion. Thanks again for everyones time. :)
  5. Alright, I have now fixed the original problem, but now I have a new one... Everything works, the display works fine, the keyboard and mouse light up and work fine in bios and everything, but once it loads up to the start of the windows install screen the keyboard and mouse lose all power, as in, lose all the backlighting, and they stop functioning. But the display still works.
  6. Do you have all the drivers installed for USB, Asmedia USB 3.0 Driver V 1.16.20, Intel 3.0 USB Driver V1.0.5.235' also you have to install the software for your keybord and mouse.
  7. I fixed that last problem but simply plugging the mouse and keyboard into the usb 2.0 plug ins. Now, when I went to install windows onto my old windows hdd it gave me error "windows is unable to install to the selected location error 0x80300024". I read a fix on some forum that said to unplug all hdd's besides the one you are trying to install windows on... So I did and when I boot up it gave me "BOOTMGR is missing" error. I replugged in the hdd and checked all the cords and bios settings and still I continue to get that "BOOTMGR is missing" error.
  8. I have no idea why it wont let me boot my old windows install that worked fine before installing the new mobo. It even detects it in the windows setup. Thank you for your time.
Ask a new question

Read More

Motherboards Displays