Sign in with
Sign up | Sign in
Your question

BIOS Update on ASUS Sabertooth P67 causing issue

Last response: in Motherboards
Share
January 13, 2013 4:00:13 AM

Hey guys,

So tonight I stopped by my motherboards support site to DL my USB 3.0 Drivers since I had not installed them the last time I reformatted. I ended up seeing a BIOS update that improves stability and performance for Windows 8 so I decided to go ahead and update. I restarted, booted into bios and flashed it. It said it was successful and to restart; upon restarting it displays:

Marvell 88SE91xx Adapter - BIOS Version 1.0.0.0022
PCIe x1 5.0Gbps
Adapter 1 Disks Information: AHCI Mode
No hard disk is detected!

Which is fine it normally says that but after that my computer just restarts repeatedly. I cannot access BIOS. I've tried clearing CMOS three times now, and each time the menu pops up for me to enter the BIOS setup but as soon as I hit the button to go to setup it restarts again. I've unplugged all HDDs and Optical Drives and even all RAM sticks except 1. Anyone have any ideas I have no idea what to do next?

Thanks.

My comp specs:
Intel i5 2500k
ASUS SABERTOOTH p67 B3
8GB DDR3 1600 G.SKILL RAM
500gb WD HDD
Radeon HD 6950 2GB
January 13, 2013 4:18:56 AM

Whenever you flash the bios it will be completely reset to factory settings, go through the bios and you may need to adjust some of your settings again.

Is it possible to roll-back the bios version, or try to flash it again?

Are you running anything over-clocked?

Is your RAM running on it's recommended X.M.P settings?
m
0
l
January 13, 2013 4:23:10 AM

That's the thing I haven't been able to get back into BIOS period even after clearing CMOS 3 times. The dialog pops up to enter setup to reset BIOS but I press the key and it just restarts again. And yeah everything is running at normal settings, CPU and RAM.
m
0
l
a b V Motherboard
January 13, 2013 4:32:44 AM

Ram can also cause this so try in another ram. remove cmos battery then power on (don't insert cmos battery) , remove gpu then power on. now u goto bios then load default settings in bios.
m
0
l
!