Sign in with
Sign up | Sign in
Your question

Memory_management BSoD.. I think it's my ram

Tags:
  • Corsair
  • RAM
  • Memory Management
  • Blue Screen
  • Memory
Last response: in Memory
Share
January 13, 2013 9:05:37 AM

Hi all,

I recently built a new rig, and all was fine for the first few weeks. Then one day I got a BSoD. Then another, and another. I did some investigation and found that most people found this particular error (memory_management) to be their ram.

I did a full, clean install of windows and the drivers/updates before starting down on the path of day long test cycles.

I downloaded and ran memtest86+ on the four sticks of Corsair Vengeance 16gb (2133mhz) ram I had and within the first pass (around test 7 and 8) at had 7 errors. I stopped the test to check online what some of the results meant. I didn't really find anything I could understand but I did find info on what to do next.

So I redid the tests on each stick one by one and ran two passes on each. None had errors. I redid this test moving the solo stick along the dimms slots one by one, again no errors.

I popped them all back in, was greeted with a "your hardware has changed, please configure (or words to that effect) and went into the bios. I turned off xmp and set the clock speed down to 1333mhz (this was by accident, i actually meant to put it up to 2133mhz) and continued to boot windows.

I had another read online trying to figure out what was happening with my memory. I tried to stress the machine by playing some games. Surprisingly I found that I could run BF3 for 3-4 hours without a BSoD (which is a big deal, as I'd usually crash within an hour of playing games previously).

So last night I popped the ram clocks back up to 2133 and ran memtest again over night. Frustratingly I found I had 28 errors this morning (see the image below).



I'm not a memory expert, most of my ram has worked right out of the box in the past, and I've only ever had one dead stick in all the rigs I've built.

Any pointers or tests to run would be helpful.

Thanks

More about : memory management bsod ram

January 13, 2013 9:50:50 AM

When I run the ram at 2133mhz, games like BF3 crash with a 0xc0000005 error. Having googled this I found "The error 0xC0000005 is generated by an illegal "memory access violation". This can be caused by anything from faulty RAM".

Is the ram faulty, or just under powered. Screenshots of my bios config below.



January 13, 2013 11:20:52 AM

(i've also raised the same post on the Corsair community forums, I'll keep both updated so that I can share the solution (if any) for both forums.
January 14, 2013 9:22:36 AM

Quote:
Originally Posted by peanutz94 View Post
It could be that your CPU just isn't capable of running memory at 2133mhz. Your CPU only support 1600mhz memory so running them at 2133mhz is a fairly large memory overclock.

I would try setting them to 1866mhz and see if your BSOD's disappear.

We can go from there depending on how the test turns out.


EDIT: you could also try setting the DRAM voltage to 1.55v manually and add.2v to your system agent voltage

I also deleted the comment about testing them one at a time. Missed that at first.


EDIT TO MY EDIT: I also noticed you are not using the XMP profile. So i would suggest enabling the XMP profile first before reducing the frequency to 1866mhz. That will adjust the other voltages for you to where they need to be. XMP should be located in the OCGenie part of your BIOS.



I've set the ram to 1600mhz now, as per what my 3770k can support at stock levels, and it's completed 10 hours of memtesting and has had zero BSoD's since. I really think this was the cause!

Thanks to peanutz94 over on the Corsair Forums for the help.

Cheers
!