Sign in with
Sign up | Sign in
Your question

Asus M5A97 R2.0 Cant turn on

Last response: in Motherboards
Share
January 13, 2013 11:24:57 PM

So I just built a new computer with this M5A97 R2.0 mother board with FX-8350 CPU.

I got everything set up, power plugged in , everything look good

but after i turn the power supply on, the only thing I see is the Bios Flash LED keep Flashing

And I didn't press the button before. power on not working , memOk button not working.

I tried download the new Bio and put it in my USB , not working as well .

remove the battery on the MB to reset the whole thing , not working.

So , when I turned on the power supply , the Bios Flash LED will just Flash endlessly.

sorry about my English and thank for the help

More about : asus m5a97 turn

a c 554 V Motherboard
January 14, 2013 6:11:29 AM

It might be a short issue. Try testing the board outside the case.
Have you connected the 8 pin power cable (not the the 6+2 pin PCIe one)?
January 14, 2013 6:51:15 AM

Yes the ESP for CPU
Related resources
a c 554 V Motherboard
January 14, 2013 7:46:30 AM

Take the board outside the case. Remove the power, reset HDD led wires etc from the front panel header and start the board by shorting the 2 pins corresponding to the power switch.
January 15, 2013 1:15:17 AM

well I found out the problem. it is like I screw the motherboard to tight

when it is too tight , the Bios flash button will just flash endlessly

Even it is working now. I still not sure why this happen
March 31, 2013 10:19:21 PM

M5A97 EVO R2.0 and FX8350 work well with Windows 8, Ubuntu, Fedora and OpenSuse (last versions), but not with Windows 7.
Does any one know the reason ?
April 1, 2013 2:04:29 AM

Adition to the preceding post : all operating systems were tested with 64 bits version and the RAM is 16 Mo of DDR3 1600 MHz.
April 6, 2013 11:11:54 PM

Les pilotes Asus étaient à jour.
April 23, 2013 9:50:22 PM

I have changed the mobo Asus M5A97 EVO R2.0 with a MSI 990FXA-GD80.
THe secure boot of Windows 8 works well as it worked with the Asus mobo.
Windows 7 works well, that means the AMD FX8350 is fully suported by the MSI mobo and partially supported by the Asus modo.
Shame to Asus who lyes affirmating the M5A97 EVO R2.0 supports fully, without restrictions, the FX 8350.
!