Sign in with
Sign up | Sign in
Your question
Solved

Help! Graphics card not working!

Last response: in Graphics & Displays
Share
October 9, 2011 8:16:33 PM

Hi guys,
On the weekend i bought all my parts for a computer and built it up no dramas, installed windows and then did all the cd's that came with it.
Motherboard and graphics card Cd's.

I then went on to install World of Warcraft and after it finished installing, i decided to give my new comp a go on ultra settings. It didnt go so well. 6 FPS. tried low settings and it was on 60 fps but anything more then low it would drop to 6-9fps. So i had a look and remembered that the motherboard had an inbuilt graphics card so i disabled that. So when i re-opened wow i got an error saying: Cannot find a graphics device to play on, program closing.....

So i tried installing direct x 9 and installing the cd again and updating the drives, All without success :( .

It is a Gigabyte GTX 550 TI graphics card just so you know. If anyone knows how to fix this please help :) 

More about : graphics card working

a b U Graphics card
October 9, 2011 10:53:43 PM

^.
m
0
l
Related resources
October 10, 2011 2:38:15 AM

Ok then, ill try that when i get home from work, Do i need to install direct x 9 first before i install any drivers? Also is there any particular reason why the cd that came with it didnt make the GPU work?
m
0
l
a b U Graphics card
October 10, 2011 4:27:01 AM

The CD should have got things going, yes.
A 550 Ti should run DX11, and it should install by itself along with games and other things that use it. You don't need to go and install it.
m
0
l
October 10, 2011 8:08:36 AM

Its still not working and im still getting the same error when ever i try to play a game! Ive tried everything possible!!! Ive installed the cd, updated the drivers and still nothing!
m
0
l
a b U Graphics card
October 10, 2011 3:25:15 PM

Go into Device Manager and see what it says about your display adapters.
Does the graphics card appear to be working, aside from the fact that it doesn't do its job? Can you get information about it through GPU-Z? Does its fan spin up?
m
0
l
October 10, 2011 8:15:02 PM

It said "This device is working properly" i have not checked the fan though. But to make problems worse, I updated the BIOS and restarted and now my screen isnt working?!? The computer turns on but doesn't display!! now im more stressed than before! How can i fix this?
m
0
l

Best solution

a b U Graphics card
October 10, 2011 11:31:16 PM

How did you go about updating it?
Take out the card and use your integrated GPU, just so you can see to get the card working (set the integrated as default).
That is, remove the integrated card and restart, then set the integrated as default, shut down, put in the card and start up. Then you should be able to see what's going on with the card (settings etc).
Share
October 11, 2011 1:10:02 AM

All i did was go into my motherboard control panel and it had utilities, I saw a bios updater utility program so i installed it. Opened it up and pressed update Bios and it did then said to restart computer. Then bam computer starts up but moniter doesnt show anything just a black screen with no txt or pictures or anything!! Even if i took out the graphics card i wont be able to see anything and be able to set the intergrated GPU as default! I dont know what to do :S
m
0
l
October 11, 2011 9:00:53 PM

Best answer selected by kjoman.
m
0
l
a b U Graphics card
October 11, 2011 10:42:14 PM

Oh damn. I didn't realize you were messing with your *motherboard's* BIOS. What gave you that idea? It's generally a good idea to leave those alone.
So you don't get a BIOS screen or anything? Try with the card in and out and with the cable plugged into the card and the motherboard. That's three permutations.
m
0
l
October 12, 2011 8:19:34 PM

Yeah ive learnt my lesson on not to touch the bios, Luckily i didnt damage my bios and i fixed everything and it all works :)  Ulrta settings FTW Thanks heaps for all the help though
m
0
l
a b U Graphics card
October 12, 2011 9:48:05 PM

sweet
m
0
l
!