Sign in with
Sign up | Sign in
Your question

AsRock x79 Extreme 4 sporadic lockups

Last response: in Motherboards
Share
January 14, 2013 6:50:10 PM

I am going to start documenting my progress on trouble shooting this issue here. Maybe some will have insights for me or some may benefit from it.

System:

AsRock x79 Extreme 4 motherboard
i7-3820 CPU
Mushkin enhanced redline 4x4GB (16GB) RAM
MSI GTX 660TI video card
Crucial M4 256GB SSD
Win 7 Ultimate x64

Problem:

Since I built this rig it has been sporadically locking up on me. There is no BSOD. There is no sudden reboot. The OS will just dead lock every so often. If I am playing something with sound the sound will suddenly loop witch sounds like a horribly loud hum in your ear. At that point the only recourse is to power cycle / reset the entire rig. For some time i thought maybe this was dude to an error in windows but i became suspicious when not seeing any BSODs. Last night I booted the rig to UEFI and let it sit over night. Sure enough when i checked on it in the morning, it was locked up.

I decided I should take the matter up with AsRock.

2013-01-14 - I talked to "John" at AsRock support and we are off to a very questionable start. After explaining the issue to "john" he simply said "Update the BIOS" then "Test the memory". He asked no questions about any components. He was adamant that I test within windows even after I made it clear the problem presents its self without windows being booted. He seemed more to just want me off the phone than anything. I'm going to go about getting the UEFI updated first. We will see what that does for the issue.
January 16, 2013 3:10:22 PM

Update: After updating from v1.80 UEFI to v2.90 UEFI my rig has been operational after sitting powered up the whole night. That is unusual and also encouraging.
January 16, 2013 10:35:38 PM

Disable the Marvell Based SATA/Pcie controllers through the BIOS.

ASRock USB3 and SATAIII Controllers are known to cause lockups and hard freezes, disabling them can reduce the issue.
Related resources
January 17, 2013 12:27:23 AM

Witch connectors are Marvell driven? Your not suggesting that all USB3 and SATAIII connections shouldn't be used correct?

I thought USB3, and 4 of the 6 SATAII ports were driven by the intel chipset?
January 29, 2013 7:16:52 PM

Solved:

Let me be the first to say I am quite jaded when it comes to just about anyone's level 1 support. Now, I don't know the level of expertise of the person I got on the phone by calling ASRock but I did assume it was of the "level 1" variety. I was given the short, cover your bases answer and I admit was quite skeptical. Well, this is where I eat a bit of crow because it has solved the issue. The firmware update has produced a completely stable machine for over a week.

Guess there is a reason they throw those out as a first answer :) 
April 3, 2013 7:26:23 AM

Thank you for this!!! I had this problem as soon as I updated my harddrive to an SSD. I had the OCZ Vertex 3 and I was on the wrong path for SOOOOO long. Since the vertex's had such a bad rep I always assume that it was the problem. I bought an Intel SSD and was fine for 2 days... then bam same problem locked up no blue screen no reboot... I knew it wasn't the ram or cpu because this issue only started when I started using an SSD, and I had an error in my Event Viewer about some kind of problem with the ram coming out of sleep and to update my BIOS...

So again thank you, here I was on the wrong path for almost a year thinking it was OCZ's fault. I tell you computers these days just seem so much more unreliable than they used to be back in the 386 486 days.
April 3, 2013 9:01:04 AM

Wow, I'm glad you found some help here snwkill. Its frustrating not ever getting any debug info from those crashes. This seemed like such a wonky issue I wasn't sure anyone would make use of my logging but hey, I'm glad you did.

Enjoy your new found stability! .... until something else breaks... Ha!

Digi
April 3, 2013 3:03:38 PM

Well I still have to implement the fix. I actually have the x79 extreme 6 but the issue sounds so close that this just can't be a coincidence. Updating the firmware crossed my mind so many times but I always thought "nah it didn't start happening until I installed the SSD, it's got to be OCZ's fault..."

The weird part is, and the reason I never pursued it as hard was because it would only do it once a week or so at first, then one time it happened to me 3 times in one day... It was so random when it happened, and like you said there were absolutely no logs to go through for diagnostics.

April 9, 2013 4:46:55 AM

Just an update this did indeed work with my x79 Extreme6. I updated the firmware and also disabled the 3rd party Sata3 ports in the bios. I put my computer in sleep mode, leave it on, and haven't had a lock up for over a week. I would have for sure had one by now. Thanks gentlemen!
!