Sign in with
Sign up | Sign in
Your question
Solved

On-board sound stopped working for no discernible reason. Any ideas?

Last response: in Components
Share
March 10, 2012 4:02:44 PM

Hi everybody,
My on-board sound was working fine, and then I unplugged my speakers. This is something I do a lot since I use my speakers for other things besides with my computer, but this time I kept them unplugged for nearly a month. Ever since plugging them back in my computer doesn't recognize that I've plugged anything in. It's not the speakers, they work fine with everything except my computer. It's not a particular port as I've tried the one in the back and the one in the front. It's not the combination of the two as I've tried headphones. I've tried uninstalling and re-installing the drivers to no avail. While the speakers were unplugged I Microsoft Update ran a few times, I tried doing a system restore back to when the sound worked and that did nothing. While the speakers were unplugged I installed a new wireless adapter into a PCI slot (since removed for unrelated reasons), I tried removing it and removing the drivers for it, that didn't work either. I was wondering if anyone had any ideas that I have not thought of before I start looking at standalone sound cards. Any help would be appreciated.

I'm running:
Mobo: MSI P67A-GD65
CPU: Intel Core i5-2400
RAM: Corsair Vengeance 8GB (2x4GB) DDR3 1600
PSU: Corsair HX Series 650W Modular
OS: Win 7 Home Premium 64-bit
March 11, 2012 3:17:08 AM

If you used the PC while the speakers were removed, it's possible Windows disabled them in Control Panel/Sound. Check and see if your integrated sound is the default device. It may be labeled as "speakers".
m
0
l

Best solution

March 11, 2012 3:36:22 AM

Reference above:
1. right-click the AUDIO icon in the lower-right (system tray)
2. choose "playback devices"
3. make sure your onboard (realtek?) has a green checkmark
4. click "configure", make sure VOLUME is at 50% and test on STEREO

For VOLUME CONTROL in Windows, just left-click the AUDIO ICON.

Problem not solved?
Then the audio chip might have failed, or you have a more severe software issue.

If it's a hardware fail, then you need to:
1. disable the onboard audio in the BIOS (even if it doesn't work)
2. install a new PCI or PCIe addon card
3. install the DRIVERS for the card.
Share
Related resources
March 11, 2012 4:22:25 AM

You are correct, the realtek audio device (speakers) are not currently my default playback device. Unfortunately the option to make them the default device is grayed out. What does this mean?
m
0
l
March 11, 2012 6:19:14 PM

zabathan said:
You are correct, the realtek audio device (speakers) are not currently my default playback device. Unfortunately the option to make them the default device is grayed out. What does this mean?

Unless the integrated audio option got disabled in BIOS, it sounds like your audio chip may have bit the dust. Go into BIOS at start up and look for the enable/disable option for the audio.

You could try one more thing. Uninstall the integrated driver again, run Driver Sweeper from Safe Mode, have it remove any audio driver remnants that got left behind. Re-boot and see if Windows recognizes the audio chip and loads a default driver. If Windows doesn't recognize the chip (but it has in the past), then I'd say the chip has failed.

Driver Sweeper: http://phyxion.net/item/driver-sweeper.html
m
0
l
March 15, 2012 6:46:51 PM

Thanks for the help everyone. I tried everything suggested and nothing worked, so I wound up buying and installing a dedicated sound card. That solved the problem.
m
0
l
March 24, 2012 11:57:21 PM

Best answer selected by zabathan.
m
0
l
!