Sign in with
Sign up | Sign in
Your question
Closed

RAM Speed Problem...

Last response: in Systems
Share
Anonymous
a b B Homebuilt system
December 6, 2011 11:44:23 PM

Ok so I just booted up my newly completed system (in sig), and decided to root around in the UEFI for a while. Right off the bat I noticed that the RAM is only running at 1333MHz not the 1600MHz its billed as.

Now, my question is: the Biostar TA990FXE says it can handle 1600MHz RAM with no overclocck, will this problem correct or am I stuck with 4gigs of Vengeance RAM running way under its price point?

Is a BIOS flash in order here?

More about : ram speed problem

Anonymous
a b B Homebuilt system
December 6, 2011 11:55:56 PM

You should be able to set the ram speed in the bios.
Score
0
Anonymous
a b B Homebuilt system
December 7, 2011 12:00:24 AM

Well see I would but It won't let me.

I go to the NorthBridge section and it grays out everything but a few unrelated port options.

Besides it should support this right out of the box...

Anyone actually have this board?
Score
0
Related resources
Anonymous
a b B Homebuilt system
December 7, 2011 12:01:30 AM

Or should I install Windows? It seems like it should work without...
Score
0
Anonymous
a b B Homebuilt system
December 7, 2011 4:43:56 PM

Anyone?
Score
0

Best solution

January 18, 2012 11:34:40 PM

Go to the overclocking menu. Select "Manual" Under "DRAM Timing"

Select DRAM Timing and there is an option to adjust memory speed.

I have 2 x 4gig sticks of corsair vengeance 1600, and here is the problem I have found:

The TA990FXE will only properly support 1333mhz, if you select 1600mhz the board will only have 4gigs of "usable" memory.

Unless this issue is specific to just me, then you want to run 1333 until BioStar releases a bios update to fully support 1600mhz of corsair memory.

Should be noted, that I don't think the Corsair memory is on the QVL memory support list yet.
Share
Anonymous
a b B Homebuilt system
January 20, 2012 3:12:06 PM

Best answer selected by H4wk377.
Score
0
!