Sign in with
Sign up | Sign in
Your question

No sound from asus p8z68-v pro on-board HDMI

Last response: in Motherboards
Share
January 16, 2013 1:52:32 PM

I have my pc built with asus p8z68-v pro and i7-3770k, and I have a monitor AURIA EQ276W with built-in speaker. I don't have video card yet. So I use on-board hdmi output to connect to my monitor. No sound! I enabled Digital Audio over HDMI from BIOS. I selected HDMI from Realtek Manager. I enabled the monitor to select digital audio. Still no luck. Any help is appreciated. Btw, I run win7 64bit
a b V Motherboard
a b Ĉ ASUS
a b C Monitor
January 16, 2013 5:47:45 PM

Did you go into the Windows sound settings and make sure that the HDMI audio output was the default? Sometimes Windows is just layers upon layers, and this can be one such case.
January 16, 2013 6:10:02 PM

Yes, I selected HDMI as the default from Control Panel->Manage Sound Device, and click the "Test" button. Green bar moving up and down, still no sound.
Related resources
January 23, 2013 1:29:57 AM

With the combination of the motherboard and monitor that I have, I found that using hdmi cable gives you 1920x1080 with no audio device detected, hence no sound, even after I set the bios digital audio output to hdmi, and the monitor is set to accept digital audio input. On the audio devices detected from windows 7, only Realtek hdmi and Realtek spdif are available. No audio from the monitor even I selected Realtek Hdmi as default.
In order to get the native resolution of the monitor, I used a dual-link dvi cable came with the monitor and hooked it up to the motherboard dvi output, the highest resolution I can get from the selection is 1680 x 1050, not the highest resolution that the motherboard spec has claimed to be 1920 x 1200.
Finally, ordered a display port cable. Now I can get 2560 x 1440 and new audio device is detected for the monitor, which I can select as default to play audio, instead of using Realtek hdmi. I totally have no clue what Realtek Hdmi audio output is for if it is not to output audio via for the hdmi cable that I used from the beginning.
June 15, 2013 2:07:47 AM

i also had the same problem and almost gave up, but since i'm very stubborn, i looked all over the place and found the solution. actually, like all things in cmputerland, i's very simple. you need to deactivate the your default high definition audio settings. in the system control settings for audio equipment. test your sound and the mars landing is a fact! ;)  have fun all!!!
!