Solved

Building New PC, possible RAM issue.

Hey y'all,
I recently purchased parts for a new gaming rig and can't get it to boot. As in, nothing happens on the display whatsoever.
I am using a ASUS P8P67 PRO mobo and Patriot G2 series RAM (2x4GB). Here are links to both:

Mobo and RAM

When I press the power button the CPU LED blinks once and turns off (that is working correctly). The MEMOk! light, however, stays red which would indicate a RAM issue. However, I'm not good enough to know why that doesn't work exactly. I have tried reseating the RAM in each slot (only one stick at a time to minimize problems) and it still does the same thing. After that I tried holding down the MEMOk! button to boot from that so it would run a series of tests to diagnose the problem and boot correctly. Note that all the proper fans/lights on the case are working.

Is this a RAM issue, and if so, what should I buy instead of what I currently own? Thanks guys!

The rest of my parts:

CPU: Intel Core i5 (click the mobo link above to view the specs on that)
Video: GeForce 550Ti
PSU: Thermaltake 430W XP550NP
8 answers Last reply Best Answer
More about building issue
  1. Also, it should be noted that in the mobo manual it says that 4GB unbuffered and non-ECC DDR3 DIMMs are supported and that by Intel spec DIMM voltage below 1.65V is recommended to protect the CPU (my RAM is set at 1.65V).
  2. Best answer
    get a motherboard or case speaker so you can hear the beep codes .

    also try just one stick of the RAM at a time .

    and then return it anyway . Intel recommend 1.5 volt RAM for sandy bridge processors
  3. I have been using 1 stick of RAM to avoid any errors. I suppose I will return the RAM because it says 1.65V or below and it is 1.65V (thought it might pass since it was just at the mark). The only thing that made me further question it is a couple of things:
    1) I found another forum where someone had used 1.65V RAM fine (different manufacturer though).
    2) My power supply only have a 4-pin and 6-pin connection for the 8-pin EATX12V plug. In the manual it says I have the option of a 4-pin or 8-pin. It would not boot with the 6-pin but it would with the 4-pin and everything seems to run fine (besides the MEMOk! light, of course).
    Do you think it's most definitely my RAM given that information?
  4. according to newegg your psu has a 4 + 4 pin mb connector . The two 4 pin unts clip together to make an 8 pin
    http://www.newegg.com/Product/Product.aspx?Item=N82E16817153023

    but it should boot with a single 4 pin
  5. That one looks like a newer model than mine. Mine looks like this and does not have a second 4-pin connector. I'll stick with as I'm assuming it's booting fine on the power supply since everything is spinning. I'll get compatible RAM (hopefully) this time and get that red light off, then move on to any other issues from there. Thank you so much for the help outlander_04.
  6. Your 6 pin is probably a pci-e connector for a graphics card

    http://www.playtool.com/pages/psuconnectors/connectors.html
  7. Thanks for the helpufl link! I just ordered this RAM as a replacement: http://www.amazon.com/gp/product/B0043UX1WM/ref=oh_o00_s00_i00_details It's on the QVL in the manual so it should work.
  8. Best answer selected by sounds_of_science.
Ask a new question

Read More

New Build RAM Boot Systems Product