ASUS p8h67-m flash image integrity check failed

Hi there,

I'm facing a problem, my mobo don't want to update bios,
I'm downloading the bios from here: http://www.asus.com/Motherboard/P8H67M/#support_Download_30
I don't know wether it's affecting the updating bios or not (since I'm only using proc and ram) but I'm choosing win7 64bit ROM.
but it give me error message: "Image integrity check failed"
I'm trying to use the win7 32bit file but it give me same error message.

anyone could help me? :(
5 answers Last reply
More about asus p8h67 flash image integrity check failed
  1. Hi, Have you bought the motherboard as a separate component or as part of a barebone ?
  2. Hi everyone,

    I am having the exact same problem as kovzone.

    Same MB: P8H67-M, bought as a separate component
    Same messages: "Image Integrity Check failed" when I try flashing the bios with EZ Flash.
    Current BIOS version: 0304 (17/11/2010)
    Versions I tried to flash: 3802 (latest), 3706 (the one before).
    The bios image files are on an USB key that is plugged directly into the MB (no hub, no cable or anything)

    When I try flashing the bios with AI suite from within Win7 it seems to work (no error message) but then there is no change in the bios version number. In other words, AI suite fails silently while EZ flash is polite enough to complain but the bottom line is the same: no update.

    One thing is weired: the dates indicated on ASUS's website for each file are different than those that appear as the release date displayed by AI suite when it opens the image file. Actually, the date according to AI suite seems to be the date of the PREVIOUS release!

    Example:
    3802 --> 29/04/2013 (ASUS website) but 03/12/2012 (according to AI suite)
    2706 --> 03/12/2012 (ASUS website) !!!!

    Hope someone can help. Thanks in advance.
  3. Hi,
    Hard to say what's wrong.
    Some options:
    contact ASUS Support,
    leave the BIOS as it is, if the system runs OK,
    check http://support.asus.com/Troubleshooting/detail.aspx?SLanguage=en&p=1&m=P8H67-M&s=39&hashedid=LjSSn573sBqqHh8X&os=&no=937
    if none works and you still want a newer BIOS version, order a BIOS chip and replace the board's one (not the best option).
  4. Hi again ...

    Interestingly enough, I am now able to answer my own question!

    I tried all the bios versions available from ASUS, in sequential order (from 0305 onwards) and this is what I found.

    Everything is fine until v. 3604 included. All successive bios versions install successfully. Some reset the parameters and some do not, but everything works all right.

    And then, when I tried to install the next version (3702), bam! "Image Integrity Check failed"!

    I tried every other version above 3702, same thing. Then I noticed a rather cryptic comment on ASUS website next to version 3604: "Please update Bios twice when update from previous Bios version, then need CLRTC." Reading the manual, I figured out that "CLRTC" means that you need to use the jumpers to force the NV ram parameters to be erased. Ok. So I duly re-flashed 3604 and did the jumper dance. Guess what it did? Absolutely nothing. trying to flash 3702 and above still yield "Image Integrity Check failed". There, I decided to call it a day.

    There are a few other ominous signs that some kind of serious version housekeeping fuck-up occured at ASUS regarding the bios update of this MB. First, there is the date issue reported above, then the list of features reported as fixed look suspiciously the same for 3604 and 3702 (except for the bizarre and ineffective additional upgrade steps for 3604). Finally, the "Manual" download section for this MB includes a document titled "P8P67 and P8H67 Series Bios update Insert page". Sounds good. What does it contain? Some info about the boot sequence and NOTHING regarding bios update except for the title ...

    Well, all this is REALLY sloppy and quite unlike ASUS imho. Let us hope they read this and pull their shit together.
  5. I saw a fault in the original P8H67-v bios chip and replace the motherboard asus h61 series b
    64 mbitlik wore the bio. 3707 with bios programmer is needed before installing the latest version of the bios chip 64 mbitlik print, and I've written a new chip (H61 series coming from asus) and I plugged in my motherboard P8H67-V models to fix the problem. running smoothly.
Ask a new question

Read More

Chipsets BIOS Flash Error Message Motherboards