My T.V. is not working with the resolution?

Hey guys, I'm new to these forums trying to find an answer to my problem. I've googled all over the place with no answer to be found and I'm beginning to think this is an un-solved problem fix. so I'm wondering if you could help me.

So my motherboard for some reason died a few weeks ago after gaming on it and shutting it down (idk how it happened) and just last week I got a new one back and I had to re-installed windows so when I did I had to re-install all of the drivers for stuff including the graphics drivers. so I re-installed them. their are 2 black strips on each side of my LCD HDTV and usually my computer will auto-fix this but after upgrading to service pack 1 its back to normal and it wont fix it. so now I can't game because any game I open up will say "Resolution mismatch. Please fix device's resolution" and idk how to fix this. what do you guys think? its right now at 1024x768 native. I CANNOT change the resolution. please help!

System Specs
Motherboard: MSI P67A-C43
CPU: Intel i5 2500K 1155 socket, 3.3GHz
Graphics Card: ASUS GTX550 Ti (yes I've installed all of the latest drivers.)
idk what else you could guys need for information, Oh, I'm using a VGA connection.
20 answers Last reply
More about working resolution
  1. Might help if we knew the make and model number of the TV, as well as the resolution you're trying to achieve.

    -Wolf sends
  2. I'm using an Emerson LCD HDTV and I'm not trying to change the resolution, normally 1024x768 will be just fine except it shows 2 black lines on each side so the screen isn't fitting into the screen perfectly and idk why. Like I've said, normally the problem will fix itself but after a Windows update it ruined it. which btw I'm using Windows 7 Home Premium.

    If you need more details I can gladly give them to you.
  3. Make *AND* Model number of your HDTV, please. It would probably help us if we knew what the specs of the HDTV.

    You say you cannot change the resolution. What exactly does this mean? Are you unable to get an image on the screen if you do change the resolution or does it mean there are no other resolutions to select or that there are other resolutions to select, but they're greyed out??? Please be more specific.

    My guess is that there is either a setting in the NVidia Control Panel that isn't set correctly or that the driver installation didn't take. When you installed the drivers, did you go through Windows Update or did you download them directly from NVidia's web site? Have you tried rolling back the drivers (trying older versions)?

    -Wolf sends
  4. Lol I'm so sorry usually I do a good job at giving details on stuff like this I'm just frustrated with this problem.

    T.V. Model Number: LC220EM1
    when I change the resolution the T.V. will go black with a message saying "Resolution Mismatch. Please change device's resolution." and then you give it a few seconds and it will go back to the way it was. No I have not tried rolling back the drivers because when I looked at the update history and it went to service pack 1 I didn't see any driver changes in the update. However I will give a shot. and yes I did download the correct drivers. when this problem was fixed on its own games ran smoothly. Windows Update attempted to download the drivers but for some reason failed. so I went to Nvidia's website and got them myself.
  5. It wont let me roll back drivers :/
  6. Thanks for the extra info. It's pretty much what I expected, but wanted to make sure.

    I'm in a similar situation. My setup includes an Olevia 232T HDTV (1366x768) and an ATI Radeon HD4670. My problem, like yours, whenever I attempt to try any resolution other than two or three that actually work, the screen goes black and I get an "Invalid Format" message. Wait 15 seconds (normal count-down for ATI changes to be accepted before returning to previous settings) and the screen comes back.

    Now, looking at the NVidia Control Panel (my primary system has an 8800GTS-640), under Display --> Adjust desktop size and position, what is your Scaling setting set to? Full-Screen?

    -Wolf sends
  7. Also, to roll back drivers, you probably need to download earlier drivers, uninstall the "newest" drivers and then install the previous versions.

    -Wolf sends
  8. Under that it wont give me much options. it will let me move the screen around but nothing major that can fix the problem. where would I be able to find an earlier version of the graphics drivers? I think Nvidia has all the latests.
  9. Okay so I un-installed my graphics drivers lol and windows 7 re-installed them automatically lol and I got some information, no its set to aspect ratio not full screen.
  10. Um... so set it to full screen?

    Also, you can get legacy drivers from NVidia's web site: http://www.geforce.com/Drivers

    The third section down is for earlier (legacy) drivers.

    -Wolf sends
  11. I have set it to full screen before with no fix. and what are legacy drivers? also. is a restart supposed to make it work?
  12. Legacy Drivers = Earlier versions of drivers

    A restart is sometimes beneficial. It clears out the memory of loaded programs/drivers and starts fresh.

    -Wolf sends
  13. I'll try the Legacy Drivers in hope of a success, however the restart did not work. :/ I'm running out of options. How about a system restore?
  14. I just tried the website and it only offered me to download the latest drivers which it said I was already at, wanna give me more specific directions on where to go?
  15. Go here: http://www.nvidia.com/page/home.html
    Mouse over Download Drivers and click on GeForce Drivers.
    Click on the "Find" button under "Beta/Legacy Driver Search"
    Above the "Find" button on the following page, there are a number of drop down options. Change these options to match your system. For Instance:

    Geforce
    Geforce 500 Series
    Geforce GTX 550TI
    Windows 7 64-Bit (select your OS here)
    English US
    All

    Once these options are selected, click the Find button. This should give you an entire list of Beta and Legacy drivers dating back to March of this year.

    -Wolf sends
  16. Lol it lets me pick Geforce > Geforce 500 series > Geforce GTX550 Ti > Windows 7 64-Bit > English > However, not All lol
  17. Oh whoops never mind xD found it lol
  18. Okay so I installed the earlier drivers and still no fix :/ got anymore ideas? lol
  19. To be honest I don't think their is a fix for this lol my sister is gonna buy my T.V. anyways so I guess I'll buy something new then. thanks for the help, if you have anymore ideas please let me know lol.
  20. Actually I think I got something. it fixed itself after I downloaded the drivers from asus.com (due to the fact I have an ASUS GTX550 Ti) and then it corrected itself. Idk how upgrading to service pack 1 would cause this to happen. Ima try re-downloading the drivers.
Ask a new question

Read More

Nvidia Resolution Graphics