Sign in with
Sign up | Sign in
Your question

Issues since fitting Gainward Geforce GTX570 (Phantom).

Tags:
  • Graphics Cards
  • Gainward
  • Geforce
  • Graphics
Last response: in Graphics & Displays
Share
October 12, 2011 7:00:08 PM

Issues since fitting Gainward Geforce GTX570 (Phantom).

I have had serious issues since installing my GTX570.
My system seems to run fine for a while and then seems to start locking up & freezing.
For example I have been playing Deus Ex:HR and quicksaves, normally instant, start taking longer and longer until finally I have to control-alt-del out.
This normally results in windows locking up and running painfully slow. And reinstalling windows is my only solution (check discs etc don’t work).
I had overclocked my i5-750 to 3.8GHz and it was tested and running stable never exceeding 80°C. I had this config before I replaced the card and never had a problem, although I am starting to think the extra power demands (im running a 750W PSU) might be contributing to my problems? I would really appreciate some advice.

Things I have tried:

• Reinstalling windows (Home ultimate SP1).
• Updated drivers (used drivermax to unsure all at new).
• Replaced hard drive (I had some issues after a while creating a partition, new HD solved that but not this).

My rig:

• CPU: Intel i5-750 (2.66GHz out of the box) – clocked at 3.8GHz. CPU Voltage 1.35
• Mobo: Gigabyte GA-P55-USB3 P55
• RAM: Corsair 4GB (2x2GB) DDR3 1600MHz
• GPU: Gainward Geforce GTX570 Phantom
• PSupply: Corsair A50 750W

If you have got this far, i thank you for taking the time to read this.

More about : issues fitting gainward geforce gtx570 phantom

a b U Graphics card
October 12, 2011 9:17:49 PM

Do you have an old video card you can try out? Your power supply seems to be sufficient.

It may be that your video card is defective.
!