Flashing Bios

Does anyone know how to flash the bios on a motherboard? I could really use some help... I have never done it before.. I have an Asrock P67 Extreme 4 Generation 3. I tried getting a driver for my mobo and after it install it had me reboot...well now its crashing during boot and it WILL NOT stop.
26 answers Last reply
More about flashing bios
  1. Does the board boot in safe mode?
  2. I can't get it to.... once it gets past the bios screen it crashes... i can only get into BIOS...nothing else
  3. Try tapping F8 at startup, bring the safe boot menu and choose to start in safe mode.
    Or reinstall Windows.
  4. i have windows 8... hitting F8 does not bring up safe mode any more.. and i cant refresh, reinstall, NOTHING with windows... if i boot from CD.... crashes....i have to somehow reset my mobo
  5. Try this Download The latest firmware for your motherboard from the manufacturer site. Now if you have a handy usb try this guide
    http://www.evga.com/forums/tm.aspx?m=15265&mpage=1
  6. im wondering if this may have to do with usb. People are experiencing usb related boot problems with that board when using usb 3. Disabling legacy usb v2 in the bios may help but will render any usb2 ports useless and only working for 3.

    If you have anything recently plugged thats using usb 3, try take it out or perhaps any wireless or additional usb devices recently connected.
  7. I would also like to mention some firmware can flash and install right from windows. you may not even need to do that if what you download from the manufacturer site is .exe just follow the instructions in the bios firmware from the site
  8. i cant get past the screen post post BIO..... so anything to do with windows or getting into windows.. I CANT DO IT =/
  9. did you try what i said?
  10. Yes I did
  11. alright, in future i would advice against flashing bios's in windows.

    http://www.tomshardware.com/forum/289507-30-what-flash

    If you have an ezflash utility built into the bios or something similar you can try flashing it again with or use the tutorial in the link above.

    Put the bios file on a fat 32 formatted usb stick off another computer and use it to reflash your bios.

    Before you do, read up on your manual or the internet and find out if your board has dual or a recovery bios. Some require hitting one of the F keys to activate the process during POST.

    removing the cmos battery or using a pin jumper or button to clear might help too.
  12. how to i format a usb stick to FAT 32 format? and how big should the usb drive be?
  13. can format under any windows. Right click the usb stick and select format and in one of the property settings you can chose either ntfs or fat32. The size of a bios file would be like 200k or something, so size shouldn't be a problem.
  14. ok i will try that... i found this on my mobo's manufacturing site http://www.asrock.com/mb/Intel/P67%20Extreme4%20Gen3/?cat=Download&os=BIOS is it one of these two that needs to go on the jump drive? and if so.... should I leave it zipped?
  15. select which one is best for you, either should do just the latest is addresses an issue with windows8.

    Will need to extract the file and leave it bare on the device you put it on. Bios or anything before loading windows will not read inside zips and ntfs file systems. Fat32 is standard at which the basis the computer recognizes before windows loads.
  16. So just have the exe file and not the 2 .sys files?
  17. put everything that was in the zip onto the stick, the bios flash utility will use what it needs.

    Did you find a flash utility in the bios or are you using 3rd party utility?
  18. My bios has instant flash?
  19. ugh........ when i select instant flash... it says no image file detected
  20. dont know if your bios has an flash utility. i know asus has, and i've flashed with it before and it was ezflash. Thought Asrock might too since they operate uefi.


    therabidwookiee said:
    My bios has instant flash?


    you havent been very clear to what you're answering too which is confusing.

    I suggest rereading how to flash you're bios. Seems to me you tried flashing your bios through windows for god whatever reason and it screwed up. Now, the only way to restore your bios's firmware is to go through these steps mentioned above.
  21. No it has it... the question mark was more of a....is that what I need ??? Lol
  22. And no I did not try through windows at all....
  23. Doesn't ezflash already ha e to be on PC that you're trying to flash?
  24. hmm, if you didn't try to flash your bios through windows then what the hell was this driver? the hell bit i mean what kind of driver would completely screw up a system like that.

    Ezflash or whatever version asrosk has im not sure will be embedded into the bios, has nothing to do with the operating system.
  25. Ya I don't know what the crap happened.....
Ask a new question

Read More

Motherboards BIOS