Sign in with
Sign up | Sign in
Your question

Nvidia gtx 570 and asus p8z68-v

Last response: in Graphics & Displays
Share
October 13, 2011 4:19:44 PM

I've been messing on my own for days to no avail searching the internet left and right. I'm sure it's something simple that someone else would be able to help with.

Anyway, here is my issue. I ordered a nvidia 570 video card. It's not being detected in device manager, it's hooked up properly because the fan is spinning. I have it in my primary pci-e16x slot. Drives cannot install because it doesn't detect applicable hardware when attempted both via included CD and going online to download them. When attempting to manually add device via device manager, it only comes up with Intel graphics adapter. Does not recognize nvidia CD for that purpose either, as no applicable hardware.

I have two pci-e connections coming off power supply directly to video card. They are 6 pin PCI-E with the option for 8 (seperate 2 pin connector) the video card accepts a 6 pin. The video card came with PCI-E to molex 4 pin connectors, why i don't know. However, I have nothing on my motherboard or psu that would accept a 4 pin molex.

If I run the card just off the motherboard without pci-e connections the fan goes into hyperdrive.

I have an asus p8z68-v pro motherboard and Corsair professional hx750w PS

in bios i have initiate graphic adapter to pcie/pci and i have disabled igpu multi-monitor.

I'm at a loss, any help would be appreciated
a c 144 U Graphics card
a b Î Nvidia
October 14, 2011 8:17:14 PM

make sure the card is properly seat and all 6-pin power connector connected to the card (GTX570 need 2 6-pin power connector). if your PSU have 2 or more 6-pin PCI-E connector you don't have to use the molex that comes with the card. have you tried other slot?
m
0
l
a c 189 U Graphics card
a b Î Nvidia
October 15, 2011 1:49:52 AM

^+1
try that first... If all fails then you might consider that your card is defective, RMA it for a replacement.
m
0
l
!