Intel Rapid Storage RAID controller - Nothing happens with CTRL-I

MOBO: ASUS Z77-v PRO
SSDs: OCZ Vector 256gb
Keyboard: Microsoft Natural Elite 4000

Issue: After boot when the Intel Rapid Storage Tech screen comes up, there is no response at all when pressing CTRL-I. Both SSDs are detected, RAID mode is set in the BIOS, the screen comes up as it should, just nothing happens when I press CTRL-I.

I can get into the BIOS just fine, and this happens before the IRST screen comes up so I know my keyboard has power.

Things I've tried:
- Verified Legacy support enabled on USB ports
- Tried plugging keyboard into various USB ports
- Tried plugging keyboard into USB>PS2 adapter
- Tried spamming CTRL-I repeatedly
- Tried holding down CTRL-I


Any ideas on how to fix this would be much appreciated!!
9 answers Last reply
More about intel rapid storage raid controller ctrl
  1. Hi, Are the SSDs connected to Intel SATA ports? Check again.
  2. alexoiu said:
    Hi, Are the SSDs connected to Intel SATA ports? Check again.


    Hello, yes they are connected and have power. They show up both in the BIOS, and also in the IRST screen (where it tells me to select F1).
  3. I mean there's also an Asmedia controller onboard. Make sure they are not connected to the Asmedia ports.
    try also different other Intel SATA ports.
  4. alexoiu said:
    I mean there's also an Asmedia controller onboard. Make sure they are not connected to the Asmedia ports.
    try also different other Intel SATA ports.


    This board just has two Intel SATA ports, they are the gray ones. The blue ones are the asmedia ports. It seemed weird to me that the Intel ports weren't the blue ones, do despite what the manual says I tried the blue ports. On the blue ports, the SSDs did not show up at all so gray are definitely the right ports.
    Also they DO show up on the IRST screen, it's just that CTRL-I doesn't work.
  5. you should have them plugged into the SATA6G grey ports. NOT the navy blue ports.
  6. From the manual:
    navy blue ports: Asmedia,
    gray ports: Intel SATA III
    blue ports: Intel SATA II.
    Now, If in BIOS, Advanced, SATA configuration, SATA is set to RAID, then it might be a BIOS issue. Try clearing the CMOS and test again.
  7. Well, updating the BIOS seems to have done the trick. CTRL-I works everytime now. It also fixed this random issue where my wireless mouse would get lag on the pointer sometimes.
  8. If any are still having trouble with this, I also had the problem on another mobo, ASRock E3C224-4L with latest BIOS 1.50. Discussion above and on other threads didn't work for me.

    I found that if I started pressing Ctrl-I as soon as anything showed on the console, it entered the RAID BIOS after the video BIOS and main BIOS have all gone by. If I waited through all that for the Intel RAID BIOS screen with instruction to press Ctrl-I, pressing Ctrl-I then does nothing. YMMV.
  9. I have a solution! At least it worked for me. I know this has long been abandoned but if you're like me and have updated your bios, raid is enabled, and you have slow boot disabled, your drives are on the intel sata ports (not as media ports) and it still just isn't working..

    Try holding " i " and then press control. Normally you would either tap both ctrl+i simultaneously or hold ctrl and then tap i. I was desperate and did the reverse and it works every time. I hope this helps someone who comes across this in a google search.
Ask a new question

Read More

Asus NAS / RAID Rapid Storage Keyboards Motherboards