Sign in with
Sign up | Sign in
Your question

ATI HDMI audio not working with LCD TV.

Last response: in Graphics & Displays
Share
October 14, 2011 8:34:41 AM

ATI HDMI audio not working. It is set as default device but it is still not working. I am using windows 7 with radeon 3200 onboard graphics and I am connecting it to my samsung lcd tv.
It gives an error that the audio device you selected is currently turned off in windows.
Please help.
October 14, 2011 8:57:28 AM

Are the drivers updated to the latest ones?
m
0
l
October 14, 2011 10:51:59 AM

Also disable the audio to your speakers on your computer and make the LCD the primary display.
m
0
l
Related resources
October 14, 2011 12:21:38 PM

Disconnect the cable from the PC when the power is on both the tv and PC wait 10 seconds ad plug it back in
m
0
l
December 3, 2012 12:38:50 PM

I dealt with the same issue last night, and got it fixed. I new that it wasn't a card, TV, or cable issue because the machine dual boots to Server 2008 and the HDMI audio on that install worked perfectly. I tried many other strategies until I realized that the HDMI audio driver wasn't being updated when I downloaded the new drivers from ATI. I discovered this after I uninstalled the ATI drivers and realized that the audio device was still listed in the Device Manager as ATI. Using Device Manager I uninstalled the device, but it reinstalled itself a few moments later. So, I looked at its properties and found the name of the driver "AtiHtmi.sys". I did a search and found the file in two places:

C:\Windows\System32\
C:\Windows\System32\DriverStore\FileRepository\[ati subfolder name]

If I deleted the file from just the System32 folder the system healed itself by copying it from the FileRepository's subfolder. The FileRepository is a system folder, but if you are an admin and can take ownership of it's subfolder that contains the driver, you might be able to delete the backup driver's containing folder. I dual booted with Server 2008, so it was a bit easier for me.

Long story short--I uninstalled the ATI drivers, deleted the remaining ATI HDMI Audio drivers, rebooted, then installed the latest ATI drivers and it worked.

I hope this helps somebody else, too.
m
0
l
June 18, 2014 4:21:46 PM

howardp6 said:
Also disable the audio to your speakers on your computer and make the LCD the primary display.


Dear Mr. howardp6,

Three days ago I spent around 6 hours of my night trying to fix this issue. I installed a thousand drivers in different combinations. Also in different ways, like manually selecting ATI drivers instead of the Microsoft ones as many websites suggested. Not one soul mentioned what you did. I don't get how windows hasn't fix this, apparetly, easy problem but I just disable the laptop sound and Voila!

I cannot thank you enough, you save me a lot of hours and frustration.

Sincerely yours,
Siralf

m
0
l
June 26, 2014 6:28:27 PM

sam0708 said:
ATI HDMI audio not working. It is set as default device but it is still not working. I am using windows 7 with radeon 3200 onboard graphics and I am connecting it to my samsung lcd tv.
It gives an error that the audio device you selected is currently turned off in windows.
Please help.


1. ARE you using a HDMI Cable plugged into the Video Card to TV? Will not work if not.

FOR REALTEK AUDIO ONLY!!

2. GO to http://www.realtek.com.tw/

3. Find Audio Drivers and download the HDMI Audio Driver. This is a seperate driver from the Audio Card Drivers.

After accepting agreement. If page does not go to HD Audio Codecs, select it in the Quick Links column on right.

Then select ATI HDMI Audio Device.

http://www.realtek.com.tw/downloads/downloadsCheck.aspx...
m
0
l
June 26, 2014 6:51:45 PM

sam0708 said:
ATI HDMI audio not working. It is set as default device but it is still not working. I am using windows 7 with radeon 3200 onboard graphics and I am connecting it to my samsung lcd tv.
It gives an error that the audio device you selected is currently turned off in windows.
Please help.


1. Are you using a HDMI Cable from Video Card to TV? Will not if you are NOT.
(Setting the LCD tv/Monitor as the Primary Display does NOT activate sound properties.)

FOR VIA Sound Cards ONLY.

2. Go to http://www.asrock.com/mb/Intel/P43DE/?cat=Download&os=A...
This is for the ASROCK P43DE Mothboard bit will work on any MB with this sound card.

3. Download Audio Driver, second item on list.
VIA high definition audio driver ver:v7500F_HDMI
(This driver is for Win7 but will work on Win8 {choose compatability mode}.

I have used this recently on Win8.1

m
0
l
June 26, 2014 7:06:41 PM

sam0708 said:
ATI HDMI audio not working. It is set as default device but it is still not working. I am using windows 7 with radeon 3200 onboard graphics and I am connecting it to my samsung lcd tv.
It gives an error that the audio device you selected is currently turned off in windows.
Please help.


1. You Must use a HDMI cable from Video Card to TV/Monitor, will not work if not.

2. Search for HDMI Audio Driver if one of the above solutions are not for your AUDIO Card.

3. The two solutions above are the most commonly used on Mothboards in last few years.

My systems: ASROCK P43DE / ATI HD5450 and ASUS P7P55 / ATI HD5570 and GIGABYTE 965S3 / ATI R240.

All are using Windows 7, Windows 8 and Windows 8.1 with latest ATI Video Drivers

m
0
l
June 29, 2014 8:22:43 PM

Simple info for HDMI Sound output.

1. Must use a HDMI cable from video card to HDMI TV video input for sound.
a. There are VGA / DVI to HDMI cables available but these do not transmit sound.

2. HDMI sound is 2-channel Stereo only. (2 speakers)

3. Check HDMI sound out by following these steps:
a. Right click on speaker next to clock in taskbar.
b. Select "Playback Devices".
c. Highlight the HDMI device (should be first on list).
d. Right click for context menu and click "TEST".
e, Set as "Default device" for constant sound through TV.
NOTE: Turn computer HDMI volume up to 100 for test.
HINT: Turn TV-Monitor volume up to 100 for test then adjust to your liking.
Most Programs/Games have built-in sound settings. I set TV at 50 and go from there.
(TV volume comtrols HDMI volume, leave computer HDMI volume at 100.)
(test sound volume does not seem to be controlled as much by computer out)
(if scale shows green bars but no sound, make sure you are not RGB input - if using - on TV)

You now have two sound out options- TV HDMI (2-channel) and Computer (up to 8-channel)

Hope this helps and happy computing
m
0
l
July 30, 2014 10:58:31 AM

REWinfo said:
Simple (mis)info for HDMI Sound output.

1. Must use a HDMI cable to video HDMI video capable card.

Or the correct ATI HDMI to DVI dongle for your series of GPU.

REWinfo said:
a. There are VGA / DVI to HDMI cables available but these do not transmit sound.

VGA cannot carry audio but DVI can, also for Nvidia GPU's you can use any* DVI to HDMI cable and get sound on supporting Hardware.

REWinfo said:
2. HDMI sound is 2-channel only.

Wrong, HDMI supports the full 8 channels (7.1) in up to 24bit depth and 192kHz sample rate.

*damaged/broken ones wont work ;) 
m
0
l
August 7, 2014 8:51:54 AM

dacleaner said:
REWinfo said:
Simple (mis)info for HDMI Sound output.

1. Must use a HDMI cable to video HDMI video capable card.

Or the correct ATI HDMI to DVI dongle for your series of GPU.

REWinfo said:
a. There are VGA / DVI to HDMI cables available but these do not transmit sound.

VGA cannot carry audio but DVI can, also for Nvidia GPU's you can use any* DVI to HDMI cable and get sound on supporting Hardware.

REWinfo said:
2. HDMI sound is 2-channel only.

Wrong, HDMI supports the full 8 channels (7.1) in up to 24bit depth and 192kHz sample rate.

*damaged/broken ones wont work ;) 


m
0
l
August 7, 2014 9:56:56 AM

Please pay attention to topic "wording" whereas many don't and misinterpet the thread, causing following replies stay into another catagory that is totally unrelated.

The thread is HDMI SOUND out FROM video card TO TV/Monitor.
Somehow got into DVI sound OUT from video card but I went with it.

You say HCMI sound output supports 8 channels or 7.1 dolby.
Looking at "Speakers" or "HDMI' tab?
HDMI may support it but I believe truely won't use it without 8 speakers.

That is dependant on your "TV/Monitor" (2-speakers) output not the "SPEAKER" (5 computer outputs). IE: 1 channel per speaker = 2 channels is STEREO, 6 channels is Dolby 5.1 and 8 channnels is Dolby 7.1. If find any information that says different. Please post link here.

The TV/Monitor may support "virtual surround output" in the settings but that is not true Dolby 7.1 on TV/monitor.

If you have a TV/Monitor with with more than 2 speakers or sound out plugs, please post the Make&Model here.

I would be very interested in this TV/Monitor without requiring full home stereo center to get 8 channels.

LOOK at the HDMI/Digital output settings in the computer control center not the "speaker" output.

The "speaker" control center is for the "computer sound card output" ONLY, not the "HDMI Video sound output".
"VIA HD Audio Deck' = VIA sound card or "RealTek Audio Deck" = RealTek sound card.
If useing Sound Blaster look at the similar card controller panel. No HDMI tab = no driver installed.

HDMI Sound chip is built onto the Video Card and is NOT controlled by the computer"speaker" output and requires a seperate driver than the sound card driver. If your sound control center does not show a HDMI/Digital tab then the HDMI drivers are not installed.

Have found over 20 forum posts supprting this information( search = hdmi sound only 2 channels )
More searches: "does dvi transmit audio"

Now, DVI was supposed to carry sound but does not as intended. If you have different Info - post a link here.
http://www.tomshardware.com/answers/id-1668092/dvi-hdmi...

Read further down for updated DVI cable types. Cable Manufacturers.
http://mycablemart.com/help/pc_to_tv.php

Maybe nVidia has a video card that will when useing a DVI to HDMI cable - NOT - HDMI to DVI
please post link to card here for others to see. I will search and post here also.

Found nVidia shows DVI sound out using 24+1 or 24+5 which is the connector on the video card.
BUT, the support dept. needs to update thier info to match this feature, they keep refering back to using the video card HDMI video or SPDIF connector for sound when asked "DVI sound", and the pictures show the 18pin DVI which will NOT plug into the 24pin connector. (condensed from 6 hours of searching). nVidia suggests the GeForce 600 series for DVI sound - BUT - have to look for yourself, too much confusing, misdirected and double talk for posting. (Ex: Video DVI does this but this is needed (with wrong pics} but recommend using HDMI connection.)

I need to test that on my HD ATI Video card. I went straight Video HDMI to TV HDMI.
Have 18pin DVI cables, need to get 24pin DVI-D cables to test for audio.
DVI does produce near HDMI picture quality. If video has HDMI port - USE IT.

I have no Knowledge of any "special" "DVI Video Card" "Manufacturer Cables" that are video specific. I have Acer, HP, Compaq and Dell DVI video cables that came with the monitors, none of which transmit sound. I have never gotten a video cable with a video card nor, if look at package contents, does it list one. If you find a link to any "special" DVI cables, Please post here.

OK, DVI is no longer a legit description.
DVI = 18pin NO Audio ------ DVI-D = 24pin has Audio?

With technology advancing you MUST specify components properly, general descriptons do not get it anymore.
Example: there are 5 different cables, DVI 1=18pin, 1=22pin and new DVI-D 24pin, DVI-I = 28pin.
So check the video card for the +4pin ( :: ) before getting one.
http://mycablemart.com/store/cart.php?m=product_list&c=...
That is not counting the Apple/Mac versions.

NOT being argumentive and will post any links I find supporting what I post.
I research before speaking or I do not post. If having any questions, tried to cover everything concerning this issue, post it and willl try to help.

BTW: Been doing computer Build/Repair since 1983
Any links above are for information ONLY - No affiliates to sales.
Will update when I can and as new information is found.
Good Luck and Happy Computing.
m
0
l
!