Sign in with
Sign up | Sign in
Your question

Asus P5G41T-M LX and Sapphire HD Radeon 6870

Last response: in Graphics & Displays
Share
October 14, 2011 1:45:19 PM

Hi There,

I have an Asus P5G41T-M LX and a Sapphire Radeon HD 6870 1gb.

At the moment when I put the card in to my machine all the fans kick in and HDD power up but I do not think it is getting any further through the BIOS.

I know the Radeon is PCIe 2.1 and the board is PCIe 1.1 but I was under the impression that most devices were backward compatible and I should not have a problem.

The system I know is fine as when I place my 320mb 8800 GTS in the the system it boots up perfectly!

The PSU should not be an issue as this is a 1100w PSU :)  so it has enough juice!

I was wondering whether there was anyone out there that had a similar spec card running in the same board, and or whether someone could give me a definative answers on yes or no this will not work with that board model.

I have not updated the bios yet but the up date on ASUS website says the BIOS update is for new CPU Support!! so is it even worth it, if it is only for that I cannot see how it will help this issue.

I have tried speaking with ASUS but apparently you cannot phone up to ask tech questions on motherboards, for that sort of thing you have to email them and wait an age for an answer after supplying every exhausting bit of detail on your board and system!
a b Ĉ ASUS
October 14, 2011 1:52:12 PM

Quote:
I know the Radeon is PCIe 2.1 and the board is PCIe 1.1 but I was under the impression that most devices were backward compatible and I should not have a problem.


this is your problem. PCI-E 2.1 is well known to have problem working with PCI-E 1.x. you need BIOS update to make the card work properly with your card. if Asus did not roll out BIOS update for your particular board then you have to get mobo with PCI-E 2.0 standards or simply get a card with PCI-E 2.0 standards
m
0
l
!