Sign in with
Sign up | Sign in
Your question

Physx not working

Last response: in Graphics & Displays
Share
October 14, 2011 4:15:31 PM

I'm using geforce gtx 550Ti Gpu. i have dis big headache, physx is not working in my Gpu. i tried all possible ways. the problem is not wit the control panel. i have enabled physx in the control panel. have installed the latest physx software as well. i don't get the option in the game display settings to on/off Hardware accelerated physx. can anyone help me out here?

More about : physx working

a c 218 U Graphics card
October 14, 2011 4:25:49 PM

What game(s) are you playing? Have you confirmed they support Physx?
m
0
l
a c 253 U Graphics card
October 14, 2011 4:26:44 PM

I have never seen an option to enable/disable the physix acceleration in a game.
m
0
l
Related resources
October 14, 2011 4:28:51 PM

my specs are --- Intel - 3.20ghz Core I5-650 4mb , 2gb ddr3 kvr1333 ram.
m
0
l
October 14, 2011 4:32:50 PM

tried playing batman arkham asylum. in the game's display settings there is an option Hardware accelerated physx < off/...> which i dont have. wot do u think is the problem?
m
0
l
a b U Graphics card
October 14, 2011 4:32:58 PM

COLGeek said:
What game(s) are you playing? Have you confirmed they support Physx?


+1
m
0
l
October 14, 2011 4:38:24 PM

i also tried playing mafia II. I know for sure these games support physx.
m
0
l
a c 144 U Graphics card
October 14, 2011 4:40:25 PM

mario enoch said:
tried playing batman arkham asylum. in the game's display settings there is an option Hardware accelerated physx < off/...> which i dont have. wot do u think is the problem?


are you sure you already installed physx software? what version is your Batman: AA? AFAIK you need version 1.1 to enable gpu accelerated physx for the game
m
0
l
October 14, 2011 4:41:38 PM

still cant figure out wot's wrong?
m
0
l
a b U Graphics card
October 14, 2011 4:44:10 PM

Tried the game-launcher setup or in-game setup?
I saw that option in game-launcher setup, if ur game is from steam, and entering directly ingame, look for the file bmlauncher (or something) and execute that one
m
0
l
a c 144 U Graphics card
October 14, 2011 4:44:54 PM

try re-installing your driver. make sure PhysX software were installed
m
0
l
a b U Graphics card
October 14, 2011 4:46:56 PM

Another option is to uninstall through control panel all nvidia related software/drivers etc. Reset PC
Grab only the latest nvidia driver (since it's packed with drivers, physx, etc) and install only that one. Try to execute Batman again.
m
0
l
a c 218 U Graphics card
October 14, 2011 4:47:24 PM

mario enoch said:
tried playing batman arkham asylum. in the game's display settings there is an option Hardware accelerated physx < off/...> which i dont have. wot do u think is the problem?

Is Batman Arkham Asylum fully patched and up to date?
m
0
l
October 14, 2011 4:49:27 PM

yes i already tried the game launcher setup i dont have da option there. and i reinstalled physx drivers as well.
m
0
l
a b U Graphics card
October 14, 2011 4:55:31 PM

@mario enoch:
Just remembered
Tried a clean install?
Grab latest drivers, select advanced,personalized install or something like that, and check clean install. It should wipe out all nvidia stuff. Reset PC. And install all again
m
0
l
October 14, 2011 4:58:51 PM

do you think there is a problem wit da game . becoz i uninstalled all previous nvidia drivers and downloaded the latest drivers installed them and still its da same.
i tried dis be4 itself.
m
0
l
October 14, 2011 5:02:09 PM

@vitornob:
i tried the clean install option wit my old software be4. no use
m
0
l
a c 125 U Graphics card
October 14, 2011 5:24:50 PM

Just use FluidMark to check if it's working after making changes (reinstalling drivers, etc). It'll be faster and more reliable than a game.

You need to have CUDA enabled on the GPU in the Nvidia control panel and the most up to date drivers.

If you get it working in Fluidmark then it's something with the game that's the problem. If Fluidmark doesn't do GPU physics (it can run on CPU, but you'll notice) then it's probably something wrong with the PhysX drivers. Sometimes you need to copy the physx .dll files into the game/app folder to replace what's there. They're named like Physxloader.dll, cudart32.dll, physxcore.dll, etc.
m
0
l
a b U Graphics card
October 14, 2011 5:51:32 PM

Make sure to assign the PhysX to the GPU in the Nvidia control panel. (Don't use the"Auto" or the CPU options). If that does not work, uninstall all the nvidia drivers and download the latest from their website. If you have the old AGEIA PhysX drivers, unistall them all.
m
0
l
a c 253 U Graphics card
October 14, 2011 7:08:55 PM

When you install any Nvidia drivers at the end of the install there is a checklist that tells you what was installed . So uninstall your drivers and then reinstall them and see what the checklist says at the end.
m
0
l
October 19, 2011 7:11:44 PM

mario enoch said:
I'm using geforce gtx 550Ti Gpu. i have dis big headache, physx is not working in my Gpu. i tried all possible ways. the problem is not wit the control panel. i have enabled physx in the control panel. have installed the latest physx software as well. i don't get the option in the game display settings to on/off Hardware accelerated physx. can anyone help me out here?


I'm having the same problem, and I'm running a pair of 590's! Once you disable PhysX it all goes away. As you can probably imagine, I'm not buying Arkham City until blog posts confirm to me that the new game doesn't have the same ***-up.
m
0
l
!