BIOS on my ASUS MB doesn't racognize all my RAM

The bios on my Asus P5L13L-X (http://support.asus.com/Download.aspx?SLanguage=en&m=T3-P5945GCX&p=8&s=16) doesn't recognize all the 4Gb RAM installed, in the POST screen the RAM counter stops at 3200Mb.

I have independently tested both my 2Gb kingston DIMMs and in both cases the full 2Gb are correctly reported by the BIOS. When both the DIMMs are installed, the BIOS setup screen will report 4Gb total memory and 3.2Gb available.

EDIT:
- Mother board P5L13L-X http://support.asus.com/Download.aspx?SLanguage=en&m=T3-P5945GCX&p=8&s=16
- CPU Intel Core Duo E4600 http://ark.intel.com/products/32242/Intel-Core2-Duo-Processor-E4600-2M-Cache-2_40-GHz-800-MHz-FSB
- The motherboard is sold with the barebone T3-P5945GCX, the only manual available is the barebone's
- DIMMs Kingston 99U5316-033.A00LF ddr2 800 2gb.
- Graphics ATI Radeon HD 3600 with 256mb RAM
- Both DIMMs were independently tested with memtest86 on each socket and did not report any error

What else can I try?
10 answers Last reply
More about bios asus doesn racognize
  1. i have 8GB ram and 7.85 is usable. The system and OS takes up that RAM(i think). But i dont know why youve lost sooo much? almost a gig?
  2. Do you use integrated graphics? If you do the motherboard will assign some of the ram to it, depending on your settings.
  3. EDIT: everything I am finding on line cross connects to an older T3-P5945GCX barebones chassis. If that is what you have, then what I am seeing is accurate, otherwise, apologies, blame Google. Its an older E-IDE motherboard according to the manual on line. I am betting the maximum amount of ram supported is 3.2GB.

    I have had the same issue with older MBs in the past, even with a 64 bit OS loaded.
  4. Thanks for the replies. I use a ATI Radeon HD 3600 with 256mb RAM.

    Some updates:
    - I ran a memtest86, the test detects 3.2gb enabled memory as well, but if I let it probe how much memory is available it will at first detect 3.4gb then crash after corrupting the screen.
    - The dimms I am using are Kingston 99U5316-033.A00LF ddr2 800 2gb.

    Also the manual at the link I provided says I can install maximum 2gb of memory, but the bios says I have a total of 4gb (and 3.2 enabled) and every memory vendor I find on google says my barebone supports 4gb memory.

    Since memtest86 eventually crashed, I'm considering the possibility that my ram is faulty and I'm thinking to get me 2 new dimms (maybe this time buying 667mhz as the manual says, instead of kingston 800), but the above leaves me rather confused....

    EDIT: groupdrat, yes, that's what I have, it's a T3-P5945GCX with a P5L13L-X mobo, where can I look to be sure 3.2gb is the maximum? What would it be the reason the bios displays 4gb total on 3.2 enabled if the mobo supports only 3.2gb?
  5. It could be likely that the ram is faulty if its not being detected completely even on a 64bit system. Try the stick(s) in another PC and see if it works.
  6. With a 32bits CPU, memory-mapped IOs end up overlapping physical RAM and make it unusable. That's probably why you end up with only ~3.2GB usable.
  7. @jaideep1337 thanks, that's a good idea, but my only other desktop pc in my house has a P4V8X-X with 3 slots of 1GB max each, I think my 2gb kingston wouldn't work there.

    EDIT: I have tried both dimms independently and both showed 2048mb when mounted, but I didn't run memtest on them. I'll try that and let you know, this way faulty memory should be revealed, shouldn't it?

    @invaliderror My CPU is a Intel Core Duo E4600, it should be 64bit, http://ark.intel.com/products/32242/Intel-Core2-Duo-Processor-E4600-2M-Cache-2_40-GHz-800-MHz-FSB
  8. fabriziocip said:
    @invaliderror My CPU is a Intel Core Duo E4600, it should be 64bit, http://ark.intel.com/products/32242/Intel-Core2-Duo-Processor-E4600-2M-Cache-2_40-GHz-800-MHz-FSB

    Another possibility is that the 945G chipset might only be able to process 32bits addresses so everything still has to be squeezed to fit. IIRC, that chipset was mainly intended for P4s and most P4s at the time did not support x86-64.
  9. I have tested both my DIMMs and memtest86 did not report any error. Both were working with 2048mb, I have even tested each DIMM on the 2 different mobo sockets. I guess this exclude the possibility the memory is faulty. My hope now is the kingston 2gb dimms are not fully compatible with my mobo, so that I can replace them with 2 compatible dimms.

    Isn't there really a way (a software or something) to determine how much RAM can my mobo/CPU support?
  10. I have same problem
    I have asus p5ld2
    memory in pc 6 Gb and cpu core 2 duo cash 4 m
    but the pc show me error ( cpu ucode error ) and the Bios can't read more then 3.2 Gb of memory ram ( total 6 Gb but available 3.2 Gb )
    windows 7 64bit but it can't read more than 3.2 Gb
    Is there any solution Or change The Motherboard ?????
Ask a new question

Read More

Memory Asus BIOS RAM