Update bios: Z68 Pro3 Gen3 for Ivy Bridge - need help

Hi all,

I got my Ivy Bridge CPU today, but need to update the bios to p2.1 in order for it to post. I've updated a bios before, but i'm having an issue getting the flash utility to recognize the file.

I have formatted 2 different USB's to Fat32 and unzipped the bios file (.10 extension) to the USB drive. The flash utility says there is no image to find. I have also tried making a small Fat32 partition--this didn't work either. I also can't boot directly to the USB. When I try this, Windows starts up.

Is there a problem with the file type i'm using? This is a relatively fresh Windows 7 install...I don't need to get certain drivers installed, do I? I have tried searching the internet for over two hours trying to get this to work. I need help here!


1 answer Last reply
More about update bios pro3 gen3 bridge help
  1. No need to install any drivers. Instant Flash is independent from the OS.

    A similar thread has been revived last week:
Ask a new question

Read More

ASRock BIOS Motherboards