Sign in with
Sign up | Sign in
Your question
Solved

How hard should I be pushing on the 24-pin ATX mobo power supply?

Last response: in Systems
Share
December 11, 2011 10:27:39 PM

I've gone through about a dozen attempts to push in the 24-pin PSU power cord into my ASRock Z68 Extreme 3 Gen 3 motherboard, but stopped each time as the motherboard was bending in slightly and I was pushing hard enough to tip the case.

I've already plugged in the 8-pin 12V power connector into the mobo with very little problems, and managed to get both 6-pin PCIe cords plugged into my GPU after a lot of struggling and demoralization upon hearing "crinkling" sounds due to force, making me worry that I broke the graphics card.


I've double and triple checked, and yes, this is the right cord, and yes, my mobo has the right 24-pin slot for it, and yes, I'm pushing it in on the proper side, matching the little secure-lock clip up with its surface pair.

I'm just really worried about damaging my motherboard, and this whole process of building my PC has been a process of freaking out and worrying. I'm hoping that mobos and GPUs are a bit sturdier than I think, but still, I'd like to stray on the safe side, and thus I ask if anyone can tell me if it would be okay to push even harder than I'd like to in order to get the plug in.

Also, is it normal for motherboards to bend a lot? Pushing the RAM in was quite worrisome...


Thanks for the help.

Sincerely,

A worried builder.
a b V Motherboard
December 11, 2011 10:58:19 PM

It shouldn't be that hard to insert the 24 pin. Just make sure you are attaching it the right way. Is it a straight 24 pin or a 20 +4 pin attachment?
December 11, 2011 11:05:12 PM

tinmann said:
It shouldn't be that hard to insert the 24 pin. Just make sure you are attaching it the right way. Is it a straight 24 pin or a 20 +4 pin attachment?


It is a 20+4 pin, the 4 part being pre-attached but removable.
Related resources

Best solution

a b V Motherboard
December 11, 2011 11:13:13 PM
Share

It is normal to have some flexibility. If you are worried too much, just put something underneath temporarily, I usually use a piece of rubber. Push the connector all the way in, make sure it is secure, then retrieve the rubber. Voila!
December 11, 2011 11:22:45 PM

darkguset said:
It is normal to have some flexibility. If you are worried too much, just put something underneath temporarily, I usually use a piece of rubber. Push the connector all the way in, make sure it is secure, then retrieve the rubber. Voila!


That sounds like a smart thing to do; thank you very much! I'll give it a shot.
December 11, 2011 11:28:53 PM

I used the tapered end of an eraser to give a little bit of resistance and applied a constant force, and voila!

Thank you very much darkguset!
December 11, 2011 11:29:04 PM

Best answer selected by nickmo94.
a b B Homebuilt system
a b ) Power supply
a b V Motherboard
December 12, 2011 12:19:11 AM

I have had problems fitting some power supplies 24 pin connector due to the latching piece of plastic being to wide causing it to foul adjacent capacitors. You should check this if you are having difficult fitting the connector.
a b V Motherboard
December 12, 2011 6:27:59 AM

Glad you got it working!
:) 
December 14, 2011 1:07:22 AM

darkguset said:
Glad you got it working!
:) 


Thanks, but it's not :( 

Well, the power itself seems to work, as the mobo lights go on and all that jazz, but I'm currently stuck at no-POST sound troubleshooting....

My last post on this thread http://www.tomshardware.com/forum/329633-31-damaged-com... is where I'm currently at in the troubleshooting process, so if you have the time to look over it, I would greatly appreciate that!

The thread started off about concerns that the no-POST was due to static, but the forum members seem to indicate that such was unlikely. Thus, I'm trying to fix the problem using other methods.
!