Sign in with
Sign up | Sign in
Your question

Gigabyte 990XA UD3

Tags:
  • Motherboards
  • Gigabyte
Last response: in Motherboards
Share
January 25, 2013 11:25:20 AM

I'm having problems with my Gigabyte 990XA UD3 motherboard,

I accidentally put to many volts into my North bridge - broke my system
I have to remove my bios battery to get my system to work again. I have been having problems
with my motherboard SATA connections, RAM won't run at right speed and can't install sound - lan drivers.

I think my motherboard is broke but want a second opinion on anything to could be.

Is there anyway I can test my cpu to make sure it's okay? memory already testing with memtest86 and passed.

More about : gigabyte 990xa ud3

a b V Motherboard
January 26, 2013 2:08:56 AM

If it works after unplugging and replugging the CMOS battery then the motherboard might be ok.
Enter bios then reset the settings to the default. Update the bios.
What problems have you been having with the Sata connectors?
January 26, 2013 9:55:26 AM

Updated bios already and clocked my processor back to stock. The problems with the sata ports were it wouldn't recognize hard drives etc and since posting this I have got the system to be fully function apart from my on-board audio won't work. I have gone through the usual motions of uninstalling disabling and updating and it won't work.
Related resources
a b V Motherboard
January 27, 2013 1:07:34 AM

Are all the ports of the audio doesnot work or just the front ones?
Are you using a internal audio device or a pci audio device?
January 27, 2013 10:40:08 AM

All audio devices on the board and the header are dysfunctional but I have sorted it now by just buying a cheap Creative Sound Blaster. Saves me getting another motherboard and it's working.
a b V Motherboard
January 28, 2013 3:49:33 AM

Make sure that he audio device is not disabled in device manager.
January 28, 2013 7:46:57 AM

Yeah all done and working fine thanks :) 
!