Sign in with
Sign up | Sign in
Your question

Accidentally deleted chipset display driver

Tags:
  • Radeon
  • Chipsets
  • Graphics
  • Displays
Last response: in Graphics & Displays
Share
October 18, 2011 12:33:43 PM

Hello,

I accidentally deleted the ATI Radeon 9550 graphics driver (including the chipset drivers) and now the monitor will not work in Windows. I can hear Windows is starting but screen is black. How can I fix that?

More about : accidentally deleted chipset display driver

October 18, 2011 1:29:37 PM

Turn off the computer
power on and tap F8 on the key board like a mad man.
This will open windows safe mode options
choose safe mode with networking, windows will load with the basic video driver
go to Ati site and download the new driver and install it.
October 18, 2011 1:37:47 PM

I tried Safe Mode and VGA mode, but it didn't work. Will try with networking as well and update.
Related resources
October 18, 2011 2:27:29 PM

No, didn't work. The problem actually started because the screen gets all pixelated. I wanted to remove the graphics display driver, but accidentally checked the remove from chipset option (the NOT RECOMMENDED option) because the screen was all fuzzy and I couldn't see well what I was doing. And now the display will not work at all after Windows starts.
October 18, 2011 2:34:23 PM

Hi, try a system restore, else go on your manufacturer website and download the driver / or install from cd
October 18, 2011 4:13:35 PM

^ Great idea, if they could see - Monitor is not usable.

Try booting to the windows Installation DVD and try selecting Repair.
October 18, 2011 4:43:40 PM

It sounds like your monitor died. I completely uninstall the drivers each time I want to upgrade to newer ones. Then I reboot, install the new drivers, and reboot again. Windows has default drivers when the ATI/AMD ones are gone.

If it displays the usual chipset stuff until Windows starts up, it may be something else.
October 18, 2011 8:39:02 PM

Thx guys. Actually the monitor works. I can enter in theBIOS mode, and i see the windows splash screen, but then goes black. and there is still pixelation
i should try to find my windows installation disks i guess
October 18, 2011 11:49:31 PM

If the bios and post screens appear correctly then chances are the issue is with windows or the driver. It is possible the issue is with the monitor or video card, some times pixalation or corruption is only visible at higher resolution or under load. Can u test that video card in another computer, or try dif video card? If it is on board video you can try a pcie or even a pci video card.
!