Sign in with
Sign up | Sign in
Your question

ACHI to EIDE Windows 8

Last response: in Motherboards
Share
January 25, 2013 7:36:54 PM

Hello, I'm trying to go back to eide in bios on a dual boot system, windows 8, XP. I'm currently have the bios set to achi. now when I select xp as my os, it wouldn't boot. so I change the bios to eide, i don't get as far as the os selection. so I switch back to achi w8 says there's a problem, try
to fix, fails after 15 minutes of blinking icon, select advance and then I can boot. So at least I can recover

I want to set it back to eide, see if i can upgrade xp to work with achi and then go back to achi. not normal to go from achi to eide, so i'm not finding much help. seen some references to set storachi(msachi) and pciide to zero but that's their current value.

More about : achi eide windows

January 26, 2013 3:56:28 PM

Solved! - I got this info from mywindows8.org
http://mywindows8.org/change-from-ahci-to-ide-mode-in-w...

The solution from Nick

Hi, Bruce try to change your default OS from Windows 8 to XP, then perform the steps.

My reply to Nick

Great idea!!!. That worked. Changing the default OS to XP caused the boot loader to use the old text style to select the OS. Before, with W8 as the default, I was getting the new Windows interface to select the OS. And I’m assuming that the Windows interface needed ACHI to run since that’s what it was installed with.

Since you can twiddle with the registry to go from eide to achi, I think you should be able to untwiddle the changes to go from achi to eide. Possibly the dual boot added another twist although one reason to go from achi to eide is to get back to XP which was installed with eide. So I don’t see why others didn’t have the same problem I had and would have expected to see more postings about the issue. Maybe because I had W8 which has the windows os selector and the others had either w7 or vista with the text style. Would have been better to install XP using F6 with a floppy for the sata drivers or slippstreamed them in. Something I’ll probably look at later in case I need to rebuild the XP side of the system now that I’m smarter.

A note – when I used the text style to select XP, I got an error message something like remove all disk drives. I just hit return and then XP started to boot. I did have a usb stick inserted, maybe this caused the error message.

Thanks again!!
m
0
l
!