Ram or mother board faulty? Debug code 53 on a gigabyte ga-z77x-ud5h

Hello, this is my first pc build i'm putting together, I currently have a gigabyte ga-z77x-ud5h with G.SKILL Ripjaws X Series 8GB (2 x 4GB) 240-Pin DDR3 and I get a debug code of 51 at first and when i tried to test the ram, i only put one into slot 1 and got error 53, in the manual it says 50-55 is memory issues so I'm coming to you guys for help on trying to figure this out
3 answers Last reply
More about mother board faulty debug code gigabyte z77x ud5h
  1. I have the same problems this is my summary of the problem and what I have done to solve it - looking for help too on fixing it ...

    Hi All,

    Topic: MB GA-Z77X-UD5H BIOS Start Debug LED Codes Codes 15 then 53 followed by restart

    I am currently building my first computer using the following components:

    My PC build consists of:

    - Corsair 800W PSU Gaming Series
    - Antec P280 Case (size, air flow, sound proofing, wiring)
    - Gigabyte Motherboard - GA-Z77X-UD5H
    - CPU Processor: Intel Core i7-3770k
    - Corsair Vengeance Ram - 8 GB X 4 (32 GB Total and maximum for this motherboard) (CMZ32GX3M4X1600C10)
    - SanDisk Solid State Drive (main boot) - 240 GB

    On start up I have the following Debug LED Codes:

    Regular Boot

    Code 15 - "Pre-memory CPU North-Bridge initialization is started. (Which I assume means the Intel Chip is initiated)"

    Error

    53 (50-55) - "Memory Initialization errors occurs". (Which I am not sure which memory this refers too)

    I have the same code sequence without RAM.

    I have the same code sequence with one 8GB RAM of the Vengeance Ram placed in all four slots and tested in turn.

    I have the same code sequence with one 4GB RAM of Integral DDR3 1333 Mhz DIMM Ram in all four slots and tested in turn.

    What memory is the BIOS trying to initialize would this be RAM or hard disk drive.

    Aside from return to the supplier and ask for more recent version of the Gigabyte Motherboard as I understand that there is a REV:1.1 available.

    The Revision Number of mine is: REV: 1.0 of the GA-Z77X-UD5H motherboard.

    I have also tried Clear CMOS and taken the battery out to also reset the CMOS.

    Any other suggestions would be really appreciated.


    Thank-you,

    Graham
  2. I have the same problem. I fixed it by taking everything out (leave your CPU seated with cooling of course. Then you would use a jumper by the BIOS switch located on the bottom middle of the MOBO and leave it for a good half hour unplugged if you have the patience to wait a day I'm sure it'll work as well.

    After you have waited, take jumper out and place CMOS battery back in and try to start it without GPU and RAM to purposely trip a error to see if your MOBO is working correctly. If you hear a beeping from the MOBO speaker then you should be good. Reseat everything and start it up, it should be good. Hope this helps
  3. a latest bios update should keep memories better.
Ask a new question

Read More

Motherboards Gigabyte Debugger