Sign in with
Sign up | Sign in
Your question

Unique File Sharing Problem

Last response: in Networking
Share
May 22, 2005 2:14:26 AM

I have two PC's running XP connected to a 802.11g router. PC A has a wired connection, PC B is wireless. Both PCs can access the internet just fine. The problem: PC A can access files on PC B, but PC B cannot access PC A.

I can see the workgroup from PC B in my network places, but when I click it says PC B does not have access rights.

I have confirmed that file sharing is enabled on PC A. I can ping PC A from PC B. My router config page shows both PC in its DHCP connections. What am I missing?
May 26, 2005 6:44:49 AM

have you shared any drives/folders on PC A?
May 28, 2005 2:56:33 AM

In addition to sharing a folder on PC A, check your firewalls. Make sure that the WinXP firewall on PC A has File and Printer Sharing checkmarked as an exception. If you are using a third-party firewall, you may need to put PC B's IP in its Trusted Zone.
Related resources
June 23, 2005 5:13:53 PM

It's a workgroup service issue. When I get home, I'll tell you what security policies need to be enabled and what services are required as well. I'm not at home right now, I'm on a real crappy work computer.

Just search in google for the exact error message and you'll probably be able to find the services and security policies needed before I get back to you. One service is the computer browser, I believe.

umheint0's phat setup --> <A HREF="http://home.cc.umanitoba.ca/~umheint0/system.html" target="_new">http://home.cc.umanitoba.ca/~umheint0/system.html&lt;/A><--
June 24, 2005 1:56:43 PM

all of the above that was said, and i find it helpful when those changes are made.. not only do a PC reboot... You should restart the router, AP's and whatnot and get a fresh new start so it recognizes everything.

hope that helps.

Asus A7N8X Deluxe
80gb Maxtor
200gb WD 8mb cache..
Lian-Li PC-60
LiteOn 52X/LiteOn 811s DVD-RW
AMD XP2800+
LeadTek GF4Ti4200 128mb
Hitachi CML174
1GB Corsair XMS PC3200
June 24, 2005 2:53:19 PM

what OS on each machine?

<pre> \|/
jlanka (. .)
___________oOOo_(_(_)_)_oOOo___________
</pre><p>
June 24, 2005 5:40:31 PM

Read this through before actually doing it.

Okay, what you want to do (and this is just the easy fix, there are other ways too) is first enable the guest account on both machines. You have to do it the back-door way. Go into the control panel - administrative tools - local security settings - local policies - security options.

Then, enable the Accounts: Guest Account Status option.

Under User Rights Assignment, make sure "Access this computer from the network" has "Everyone" listed there, as well as everything else.

Now, back under Administrative tools, go into services. Make sure the following is configured:
Computer browser - started, automatic
Secondary logon - started, automatic
Server - started, automatic
Workstation - started, automatic

Then, restart the machine. Now, most of what I said here actually applies to PC A. It's PC A that's not allowing PC B to access it. There is one last thing to add, as well.

In the dos prompt, type in net share. If IPC$ is not listed, then type in net share IPC$. That could also affect PC A.

All that may take care of it. If not, feel free to reply back with the specific error message. And, like I said, Google is a big friend with networking issues.

umheint0's phat setup --> <A HREF="http://home.cc.umanitoba.ca/~umheint0/system.html" target="_new">http://home.cc.umanitoba.ca/~umheint0/system.html&lt;/A><--
June 24, 2005 6:23:07 PM

Anyone notice he hasn't posted back, so I assume he probably isn't checking this or he has it fixed.

When working in a Workgroup using 2k or XP, you need to authenticate between PCs. Meaning each PC has to have the same account set up on it. Each computer needs the same user account and password on each computer.

username: JohnDoe
Password: Jane

That would need setup on both PCs. Then, you would have to enable File and Printer Sharing on both PCs by clicking the link stating you are aware of the risks of sharing.

By default, the C drive is shared administratively as C$. The $ hides any shares btw.

That is all you need within XP. 2k is a little easier to get setup.

XP requires authentication. XP can read a 98 computer easily since 98 doesn't require authentication. Good luck trying to get 98 to see a share on XP though because 98 really wasn't designed with networking in mind.
June 27, 2005 1:39:21 PM

minor nit..

you don't really need the same account and password on each machine, you can simply supply that as command line args on a net use command...

<pre> \|/
jlanka (. .)
___________oOOo_(_(_)_)_oOOo___________
</pre><p>
Anonymous
June 27, 2005 8:12:52 PM

oh thats intersting, my actual trick was to change the workgroup on both usually took care of most of it.
Still a workaround ill rember

Asus P4P800DX, P4C 2.6ghz@3.25ghz, 2X512 OCZ PC4000 3-4-4-8, MSI 6800Ultra stock, 2X30gig Raid0
June 30, 2005 5:38:07 PM

yeah you could use something like:


net use G: \\computer1\sharename /user:username password /persistent:yes/no

but that'd probably give a problem. It'd be easier to just create the user account on each computer.. that way he could log in to either computer with the same user/password.

But you're right in what you're statement.


Actually I was thinking he might have to disable simple filing sharing in folder options/view - last options incase something got mixed up with ownership rights on the PC.. but that's just a thought.
!