Sign in with
Sign up | Sign in
Your question

Mobo Failure Need some Insight

Last response: in Motherboards
Share
January 27, 2013 1:17:09 AM

Hello all, I'm having some trouble with my PC and I'm pretty sure my Mobos fried but I wanted to get some other points of view before I purchase a new one.

Ok so, I have an "ASRock Z68 Pro Gen3 LGA 1155" with an I5-3570k. (Had to buy an updated bios to make it work)

One night I was gaming, and decided it was time to hit the sack and turned off my computer. When I woke up the next morning it would'nt fire up. "Ok, it must be my PSU" so I bought a new one. (my old PSU was 5 years old and I thought it should be kicking it sooner rather then later). I got a new PSU and plugged everything in and nothing works now. I also found it very weird that my computer died while either powering down, powered off, or powering on.

Here are the steps I took.

Made sure all PSU cables were correctly and firmly connected.
Checked to make sure the power wiring from the case to the mobo was correct.
Removed all hardware except the CPU fan.
Checked for black or burning spots on the mobo.
Checked for sheered wires that might be causing a short.
Tested the PSU to make sure it wasnt a DOA.

Everything checked out and I couldn't find a single thing wrong, (I also don't overclock). One weird thing however is that it lights up and fans spin for a quick split second when I plugged in the 24 pin (The power was still on and it had been 2 hours of me tinkering, turning off the power had slipped my mind).

I was grounded the entire time with a static wristband. After conferring with my dad and some other very hardware savvy people we've concluded the MOBO is fired.

So I'm just asking if you guys concur or if you might see a different overall problem. (Once again I tried turning it on with only the cpu and mobo (and the heatsink) plugged in so I don't see it being anything other than being either the Cpu, Mobo, or Heatsink.)

Thanks,

-Kel

More about : mobo failure insight

January 27, 2013 1:35:42 AM

Have you Tried to remove the battery and unplug the power cord for 30 seconds? Some PC's only needed that to start running again. But if it's fried, just buy a new one. You can fix one, but, not worth it. it will fail eventually.
m
0
l
January 27, 2013 1:38:51 AM

And have you tried to test another CPU? and Make Sure the Heatsink is firmly in place.
m
0
l
Related resources
January 27, 2013 1:43:00 AM

and try to start the motherboard without the Start Button. You achieve that by using a screwdriver and touch both metal prongs, where you Plugged the Star Button.
m
0
l
January 27, 2013 2:00:11 AM

Try resetting the CMOS and replacing the CMOS Battery.

Or if your board supports it(ROG connect among others) try to flash another BIOS.
m
0
l
January 27, 2013 2:03:39 AM

Thanks guys I will try all of these. I did attempt to reset the CMOS but not the battery.
m
0
l
!