Sign in with
Sign up | Sign in
Your question

4870x2 problems (maybe psu faulty)

Last response: in Graphics & Displays
Share
October 19, 2011 1:04:32 PM

Hello,
need advie on build,
i have at present
Coolermaster Storm Scout gamers case + 2 x coolmaster sickle fans
Ezcool 700watt tournado psu
amd phenomtm ii x4 965 black edition
ATI Radeon™ HD 4870 X2
Asus AM3 M4A87TD/USB3
4x4gb DDR3 1333mhz modules (with artic cooling)
250gb western digital sata 3 HDD
2TB Western digital sata 3
1 x dvd-r/w
1 x dvd-rom
win 7 home premium (full licence)
32" HD screen
logiteck laser desktop set

the 4870x2 i think died on me the other week, got a bsd, then wouldnt boot at all, no post, no bleeps, no signal, all the fans were on but nothing, non of the leds on back of card were lit up... they come on for a few seconds then nothing...
took card out, banged in a crappy card and bingo booted up fine,
thinkiing about it i've had a few problem when playing crysis... thought it was because cpu was getting too hot as i was on stock, but changed to a vortex... and it seemed to have fixed the issue... only bsd 1 out of 10 times...

i dont have another psu powerful enough to test card on, (i know the ezcool 700w psu i got is crap), didn't know at time ezcol was a cheap make...
(getting a much better themaltake tough power 875w M) but not till i can afford it....

i did try the 4870x2 in another rig with a cheap generic 450w psu, but the card wouldn't boot because not enough power 3 leds on card came up straight away... thought it would have just booted into windows only had 1 hdd connected as well... but no

any chance it could just be the 750w psu?? heard the Ezcool brand are not 80% as advertised... and is probably only a 500w max..
and have also notice a high pitched noise coming from the psu...... safe to say its staying off until i get the thermaltake... just in case

on testing, i took out the card booted and got 1 long bleep....
thought ok weird, put it back in and took out all of the RAM...
and i got 3 bleeps gap 3 bleeps..... so i thought damn RAM issue right... NO... i took all 4 sticks and tested each one on the other rig i have and works perfectly,
so then i went back and placed each stick back in rig 1 by 1 rebooting every time, same issues, no post no bleeps.... Nothing damn...

so i'm now stuck and not sure if its the psu or the card and ideas????

cheers

a b U Graphics card
October 19, 2011 2:07:22 PM

Do you have another Graphics card to try? hopefully one that's not quite so power hungry? That would tell you if your PSU is at least working, just not up to powering an x2 card..
a c 161 U Graphics card
October 19, 2011 2:13:50 PM

He already has.

I am willing to bet it is a shoddy PSU. (probably only the PSU too)
Related resources
a b U Graphics card
October 19, 2011 2:22:58 PM

Novuake said:
He already has.

I am willing to bet it is a shoddy PSU. (probably only the PSU too)

Oops :??:  Just re-read the OP, My bad! Here is another vote to the PSU being the problem! :bounce: 
October 19, 2011 7:20:22 PM

thanks for the reply's,
sorry if this double posts.... weird lol

the psu is defo working, as the rig is working fine, just not with the 4870x2 in it..... take it out slap in the crappy asus GF 210 and bingo boots up fine...


ok so i'm going to buy (at the missus's expense) the thermaltake 875w...no shoes for her this month hah....
or do i buy a
coolermaster silent pro 850w m (as i have a coolermaster scout case)

this will hopefully answer my question... about the 4870x2

but also.... if the 4870x2 is working..... i know its a good card BUT... its not dx11 compatible....
so i was thinking of spendng a bit on a decent dx11 card, and selling

looking at ati radeons, hd 6850, 6870 BLACK Edition

any thoughts pleas
a b U Graphics card
October 19, 2011 8:18:16 PM

lonewolf1911 said:
thanks for the reply's,
sorry if this double posts.... weird lol

the psu is defo working, as the rig is working fine, just not with the 4870x2 in it..... take it out slap in the crappy asus GF 210 and bingo boots up fine...


ok so i'm going to buy (at the missus's expense) the thermaltake 875w...no shoes for her this month hah....
or do i buy a
coolermaster silent pro 850w m (as i have a coolermaster scout case)

this will hopefully answer my question... about the 4870x2

but also.... if the 4870x2 is working..... i know its a good card BUT... its not dx11 compatible....
so i was thinking of spendng a bit on a decent dx11 card, and selling

looking at ati radeons, hd 6850, 6870 BLACK Edition

any thoughts pleas

While the PSU is working, it may not be able to supply enough current for the 4870x2 GPU to work. I would take the CM Silent Pro as I believe it got higher ratings than the Thermaltake, Although I would rather have a Corsair, Antec or Seasonic
PSU. I currently have a HD6870 Black GPU & it works great!

Good Luck!
October 31, 2011 1:36:17 PM

was the psu t fault, managed to pick up corsair 850w cheap, so happy days, system is now ok. well apart from the 4870x2 is dead ;(

think the crappy psu must have blown card...

so now having to get a new card....

thinking of

asus 6950 either 1 or 2gb not too sure which to go for???

any comments on good cards for around the £150 mark? or maybe a crossfirex with 2 cheaper cards?

!