Sign in with
Sign up | Sign in
Your question

External drive extremely slow

Last response: in Windows 7
Share
December 30, 2011 7:08:02 PM

Hello,
I have a new Hitachi 2 terra bite drive. It is only transferring data at 900 k per second. It needed all day to transfer a 28 gig file. I go to Device manager and it says it is transferring at 2 % withband. It is windows 7 so I am sure it is usb 2.0
Whats up. any ideas. Keith
a b $ Windows 7
December 30, 2011 7:31:56 PM

kcole83080 said:
It is windows 7 so I am sure it is usb 2.0
Just because you're running Windows 7 does not mean the USB port is USB 2.0
m
0
l
a b $ Windows 7
December 30, 2011 7:39:36 PM

Are you running the USB connector through a USB hub or plugged directly into a USB slot on your PC?
Have you tried your other USB slots? Same slow performance?
m
0
l
Related resources
a b $ Windows 7
December 30, 2011 8:09:34 PM

Have you installed motherboard chipset drivers?

Also with the USB drive plugged in, go into Device Manager --> Disk Drives

You will see it, right-click --> properties --> policies --> tick both

This will increase the drives performance, but you can't just unplug it now, you have to use the ejection icon found in the system tray to avoid data corruption.
m
0
l
February 21, 2012 5:40:16 PM

I know your pain, i also bought an external drive for keeping large video files on, usb 2 is slooooooowwww. At best I usually got only 24Mbs transfer on usb2.
I took it back and got a PCI-e usb3.0 card and a usb3 ext drive dock. Transfer was as fast as my internal drive, Biiig difference. Sell or return your usb2 ext drive and get a usb3, its worth the price difference, which isnt much. transfer now takes minutes instead of hours.. ESATA is as fast as USB3, if you prefer that option..

Also, make sure that your external drive is on its own usb 2.0 port and not on a HUB...

When you plug in your external drive, does your computer say "this device can perform faster if you connect it to a usb2 port" ?

Run run run and exchange that usb2 for a usb3!! :) 

David
m
0
l
!