P8Z68 Deluxe / Gen 3 Wont Post Red CPU LED, No QLED code

P8Z68 Deluxe / Gen 3
Intel I7 2600K
Corsair Vengeance 8GB 1866mhz (2 4GB sticks)
Corsair H80 Closed System Liquid CPU Cooler
Cooler Master 1000W Silent Pro
Samsung 128 SSD 830 series
Radeon 5870 (I'm getting a new card when the next Nvidias are released)

I have a P8Z68 Deluxe / Gen 3 and a I7 2600k CPU, as the title says I'm getting a Red CPU Light on the Mobo, and the Q-LEDs which are designed to display a 2 character (numerical or alpha numeric) code is not even lighting up, a 00 (which is the no problems code I believe) would at least be something, but they just stay unlit. I installed the speaker that came with my case (Cooler Master HAF X) and it doesn't beep to indicate problems. I'm thinking that there may be some short-outs on the board or that something else is wrong with it.

I'm using a Corsair H80 for CPU cooling and that runs fine, I can hear the pump running and the fans are working. I have a 1000W Silent Pro power supply by Cooler Master and I'm sure I've hooked all the power cables up carefully and securely. I've tried this with everything attached down to the bare minimum attached and I still get the Red CPU LED.

No video feeds to the monitor, nothing but the fans powering up in the case and on the H80. The switch LEDs for EPU and TPU on the MOBO work, but I cannot get anything to display on the Q-LED. I've tried removing RAM, Video Card, everything... no luck...

Does anyone know if this could be anything other than a dead board? I really don't think it's the CPU b/c I've checked it and the socket and nothing looks wrong with them, I know that the human eye can only see so much, but I just want to know if I'm missing something, I don't think I am though.

I've built rigs in the past and haven't had any problem... Luck I guess?
3 answers Last reply
More about p8z68 deluxe wont post qled code
  1. I'm having the EXACT same problem.
    Red CPU LED on. No Q-LED. No beeps. No Video.

    Asus P8Z68 Deluxe/Gen3
    Intel i7 2600K
    Mushkin Redline 16GB PC3-12800 (4 x 4GB)
    NZXT Havik 140 CPU Cooler
    OCZ 850ZX Power Supply
    Gigabyte GTX570
    Hauppauge Video Capture Card
    Samsung Spinpoint 2TB Drive
    Thermaltake Level 10 GT

    For good measure I removed all but 1 stick of RAM, and the Hauppauge card, and I have the same result.

    I then took it a step further and removed the video card, and there is no change. Still no beeps or Q-LED.


    I built a similar rig a month or so ago and had no problems.
    Asus P8Z68 Deluxe/Gen3
    Intel i7 2600K
    Corsair Vengeance 16GB (4x4GB)
    Corsair H70 CPU Cooler
    OCZ 850TX Power Supply
    OCZ 120GB SSD
    Seagate Barracude XT 3TB
    nVidia 560Ti
    Corsair 800D

    *NO* Issues

    Would love to know any other troubleshooting tips to determine if this is a dead CPU or board. I *REALLY* don't want to play the blame game with Intel and Asus :(
  2. BAH, I'm feeling stupid as hell right now!

    Make sure the 8pin CPU connector is connected! It connects to the mobo right above the CPU between the two blue heat syncs.

    You know what's REALLY bad?? I DID THE SAME THING ON THE LAST BUILD!!!! (eyeroll)

    Computer geek FAIL!

    Help this fixes you up too!
  3. If you remove your memory and you can't get any beeps, your heatsink backplate might be touching the back of the motherboard causing a short. I have a P8Z68-V LE and I had a similar problem. The solution was to use the heatsink's included electrically-neutral plastic spacers between the motherboard and the backplate. That solved it for me.
Ask a new question

Read More

New Build CPUs Corsair Systems