Sign in with
Sign up | Sign in
Your question

Dell c521 wont accept 4 gig ram

Last response: in Memory
Share
January 28, 2013 6:37:47 AM

My dell c521 wont accept 4 x 1 gig modules, i know they are working as took out of another dell desktop ( different model )
it just shows up as 2gig,

Have tried cleaning contacts etc
January 28, 2013 7:20:42 AM

Try this, go to start->run->msconfig
Go to the BOOT.INI TAB.->advanced. And change the max memory to 4096.

apply and reboot.
January 28, 2013 8:31:11 AM

Thanks for prompt reply.

Tries as you suggest, in win 7 , only max u can go up using arrows is 2 gig , if you type 4096 it goes back to 2048 when u save.sure i read somewhere that euro model of this machine will only accept 2 gig if this is so would that be a bios issue or perhaps hardware?
Related resources
January 28, 2013 7:23:37 PM

lol
January 29, 2013 2:12:05 PM

well either the bios won't take 4gb or 2 sticks are bad. I'll try with a bios update first. but could be dangerous if you are not experienced.
January 29, 2013 5:49:04 PM

No sticks are not bad, they came working from my other dell, think it must be bios wont take them, as i said earlier after your advice went to try adjust the max mem in win 7 and just would not go to 4096 and if u type it in when u click save just goes back 2048, run out of ideas lol- time for a new machine, 2 gig is ok for the time just annoying cant use this ram
March 21, 2013 7:55:55 PM

MaxWonga, I had this exact problem with my dell c521.
it would not load windows with the 4 1gb sticks.
Load it up with 2 of them in slot 3 and 4.
then go to - "Try this, go to start->run->msconfig
Go to the BOOT.INI TAB.->advanced"............ and untick the "max memory" box and the field will be blank.(previously showed 2048)
turn the pc off, stick the other 2 x 1 gb sticks in and fie it back up.
sorted, boots up on the 4gb
October 26, 2013 9:05:03 AM

wmbxp05 said:
MaxWonga, I had this exact problem with my dell c521.
it would not load windows with the 4 1gb sticks.
Load it up with 2 of them in slot 3 and 4.
then go to - "Try this, go to start->run->msconfig
Go to the BOOT.INI TAB.->advanced"............ and untick the "max memory" box and the field will be blank.(previously showed 2048)
turn the pc off, stick the other 2 x 1 gb sticks in and fie it back up.
sorted, boots up on the 4gb

This actually worked for me. I've been fooling with this for almost 2 weeks without success. I would never have thought of this method. Many thanks.:bounce: 

!