Sign in with
Sign up | Sign in
Your question
Closed

XFX 6870 Display problems...

Last response: in Graphics & Displays
Share
a b U Graphics card
October 20, 2011 3:34:06 AM

Just installed my 6870, and for some reason, my display is weird, I have it set to native, yet I cant see everything on the screen. It seems to be zoomed.


- Already updated all of the video drivers
- removed the old
a c 189 U Graphics card
October 20, 2011 8:31:16 AM

umm, already tried the one inside the disk?
sometimes, the latest is not always the best...
Also make sure all cables connector are properly connected.
Score
0

Best solution

a c 142 U Graphics card
October 20, 2011 8:45:51 AM

It sounds like your overscan/underscan settings aren't correct. Go into Catalyst Control Center, go to the My Digital Flat Panels tab, and check the scaling options. Make sure that your overscan/underscan scale is set to 0%. Which cable are you using HDMI or DVI? DVI tends not to have scaling problems unlike HDMI. If you are using HDMI and you have a DVI cable, try using that.
Share
Related resources
a b U Graphics card
October 21, 2011 12:13:49 AM

Supernova1138 said:
It sounds like your overscan/underscan settings aren't correct. Go into Catalyst Control Center, go to the My Digital Flat Panels tab, and check the scaling options. Make sure that your overscan/underscan scale is set to 0%. Which cable are you using HDMI or DVI? DVI tends not to have scaling problems unlike HDMI. If you are using HDMI and you have a DVI cable, try using that.


I did use an HDMI, so thats the culprit?
Score
0
a c 142 U Graphics card
October 21, 2011 1:25:16 AM

It might be. If the Overscan/Underscan options don't fix the problem, try using a DVI cable.
Score
0
a b U Graphics card
October 21, 2011 2:01:11 AM

Best answer selected by The Halo Don.
Score
0
a b U Graphics card
October 21, 2011 2:01:30 AM

Supernova1138 said:
It sounds like your overscan/underscan settings aren't correct. Go into Catalyst Control Center, go to the My Digital Flat Panels tab, and check the scaling options. Make sure that your overscan/underscan scale is set to 0%. Which cable are you using HDMI or DVI? DVI tends not to have scaling problems unlike HDMI. If you are using HDMI and you have a DVI cable, try using that.



That fixed it, thanks so much man! :D 
Score
0
a c 273 U Graphics card
October 21, 2011 10:22:18 AM

This topic has been closed by Mousemonkey
Score
0
!