USB Issue Asrock Z77 Extreme4

"Missing USB Driver"

Installed Win 7 Pro 64.

Have updated bios.
Installed all drivers on utility disk except 3rd. party software, including Intel 3.0 USB drivers.
Device Manager still says USB Drivers Missing or not installed. (whatever the exact message says)

All updates to Win 7 installed.

Internet search for driver update does not find anything.

Also shows "other device" missing driver. (right underneath USB driver missing message)


What am I overlooking guys/gals?


Thank you,
John
8 answers Last reply
More about issue asrock extreme4
  1. Install the driver for the ASMedia usb 3.0 controller.
  2. Well... ok but have a look at this image first...
    This is an image of the relevant section of my device manager.

    http://jaxehost.com/th/usb.png

    Thanks,
    John
  3. I have the same board and I agree with noidea, its the Asmedia USB3 controller. I belive mine updated from windows automatic updates. I did not use the CD. But I may have just gone to the asrock site.
  4. Well... I have built many computers and I have never had to install a third party driver to get a USB port to work right.


    Thanks,
    J

    PS - On the driver disk and on the Asrock website, the only drivers that mention the word USB is the one for the 3.o driver. Where is the driver for the 2.0 ports?
  5. On mine the 2.0 ports just worked. The driver was only needed to get the 3.0 (high speed blue ports) to work.

    Sorry if I missunderstood, but do your USB 2.0 ports work?
  6. Well... that's part of why I am confused. The two ports on the front of the case work. I have them setup as 3.0's. But they are working with 2.0 devices.

    Did you look at the image?

    It just shows USB port drivers not installed but at the bottom it shows they are. I;m lost. SOMETHING is not working. I have not tried the dedicated 2.0 ports on the back of the case.

    Thanks,
    J
  7. From the Asrock website:
    - 2 x Rear USB 3.0 ports by Intel® Z77, support USB 1.0/2.0/3.0 up to 5Gb/s
    - 2 x Rear USB 3.0 ports by ASMedia ASM1042, support USB 1.0/2.0/3.0 up to 5Gb/s
    - 1 x Front USB 3.0 header by Intel® Z77 (supports 2 USB 3.0 ports), supports USB 1.0/2.0/3.0 up to 5Gb/s

    Do you see the ASMedia controller for the additional USB3.0 ports? Do you ever use manuals?
  8. Rarely...
Ask a new question

Read More

ASRock Drivers USB Motherboards